How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Daniel Your Own Question
Daniel
Daniel, Home Appliance Technician
Category: Appliance
Satisfied Customers: 16341
Experience:  20+ yrs. experience in white goods repair. NVQ Level 2 electronics manufacturers training courses.
15468697
Type Your Appliance Question Here...
Daniel is online now

E20 error message comes on occassionally and wont rinse without

Customer Question

E20 error message comes on occassionally and wont rinse without draining. The pump is working and the filter has been cleaned. Any ideas?
Submitted: 4 years ago.
Category: Appliance
Expert:  Daniel replied 4 years ago.

Hi

.

When you set the washer on a spin cycle do you hear the pump running?

.

And when it comes up E20 is it full of water aswell?

.

Regards

Customer: replied 4 years ago.
Pump seems to be running fine. E20 msg comes up
at different points but often when loader still has water
retained. Machine washes but not rinsing. Clothes finish
and still wet with detergent still not washed out properly
Expert:  Daniel replied 4 years ago.

Hi

.

E20 is a draining error code.

.

If the pump is running fine then it will be a blockage somewere in there.

.

First thing to check is the drain hose and were it drains to. If it goes under a sink then you need to remove the spigot and make sure this isnt blocked up.

.

Then remove the filter again and make sure this is all clear.

Then if thats fine you need to lean the washer backwards and look under there and you will see a black hose going from the tub to the pump. Remove this and make sure theres nothing in there aswell.

.

Once all clear refit the hoses and retry the washer and see how it goes from there.

.

If still the same then it will be a faulty pump. As the pumps on these can be working ok one minute and then not the next. If left for a bit it can start to work again then. So if this is the case then the pump will need to be replaced.

.

So check them out and see what you find. But i think this is going to be either a blockage or a faulty pump here.

.

If you need anymore info just get back to me.

.

Regards