How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Rob Your Own Question
Rob
Rob, Home Appliance Technician
Category: Appliance
Satisfied Customers: 6991
Experience:  20 yrs. experience with a major worldwide manufacturer.
14831508
Type Your Appliance Question Here...
Rob is online now

my id160 dishwasher is not working. it is flashing both the

Customer Question

my id160 dishwasher is not working. it is flashing both the 'heavy duty' and ' daily cycle' indicators after a couple of minutes
Submitted: 4 years ago.
Category: Appliance
Expert:  Rob replied 4 years ago.
Welcome, my name is Rob and I will be helping you with your problem today. If anything isn't clear, please just ask me.

Is it possible this is an IDI 60?

Is the water above the filters?

Can you tell me how the waste hose is connected to the house plumbing?
Is it to the U bend under the sink?

Thanks
Rob
Customer: replied 4 years ago.

hi Rob


 


It is a creda IDI 60


 


Yes the water is above the filers


 


Yes it is to the U bend under the sink

Expert:  Rob replied 4 years ago.
Hi John

Great, thanks

Disconect the waste hose at the u bend.
Put the plug in the sink, just incase !!!

Put the hose into a bucket on the top of the machine.
Select a new cycle
It should pump out the water for about 60 seconds. Switch it off as soon as it stops pumping.
Did a lot of food debris come out? or what happened?

Thanks
Rob
Customer: replied 4 years ago.

Hi Rob.


 


Nothing happened and it is flashing both the 'heavy duty' and ' daily cycle' indicators after a couple of turning itself off


 


Thanks


 


John

Expert:  Rob replied 4 years ago.
Hi John

OK, did you hear the pump trying to run, or was it silent?

Rob
Customer: replied 4 years ago.

Hi Rob.


 


There was a humming coming from the machine


 


John

Expert:  Rob replied 4 years ago.
Hi John
Thats good news

It sounds like either the hose or the pump is blocked with food debris.
You can try blowing down the hose. If it burbles through the water, try it again in the bucket.
If not you will need to bail out as much of the water as you can, then from underneath, undo the waste hose from the pump. Some water will come out, so put down old towels. (DONT TURN THE MACHINE ON ITS SIDE).
Then clear out the hose and check the pump outlet is not blocked.

Refit and try the waste hose in the bucket again.

If the pump hassiezed let me know and ill find a replacement.

In the meantime,

Can I ask you to take a moment and rate my response? Please use the smiley faces which you should now see. Please remember you are rating me personally, not the website or the problems you have had with this machine.
If you need to ask me anything after rating, please just follow the link in the welcome email
Thanks
Rob