How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask SparePartspro Your Own Question
SparePartspro
SparePartspro, Home Appliance Technician
Category: Appliance
Satisfied Customers: 1243
Experience:  Mech / Electrical Tech, Appliance Service Tech, PAT Test Eng
41227295
Type Your Appliance Question Here...
SparePartspro is online now

Hi, My Indesit DPG15WH UK dishwasher does nothing for a few

Customer Question

Hi, My Indesit DPG15WH UK dishwasher does nothing for a few minutes when mains turned on, then the "end" light and the "standby" light start to flash together very fast.

None of the buttons do anything and it just stuck flashing the 2 lights.

What could the issue be?

Harry
Submitted: 3 years ago.
Category: Appliance
Expert:  SparePartspro replied 3 years ago.

SparePartspro :

Thank You for using JustAnswer - My name is Tony and I am more than happy to help with your question today.

The 2 flashing lights are your error code.
If you where to number the lights from left to right can you tell me what number lights are flashing.

JACUSTOMER-073bmk46- : Ji
JACUSTOMER-073bmk46- : hi
JACUSTOMER-073bmk46- : Hi. It's the 3rd light that's flashing and also the start/pause lights that's above.
JACUSTOMER-073bmk46- : Hi. It's the 3rd light that's flashing along with the start/pause light that's above.
SparePartspro :

This is indicating a blockage in the drain pump or drain hose.
Remove the filter from the bottom of the dishwasher and make sure there is no debris stuck in the sump.
Fill it with water from a bucket, press start and then close the door.
Make sure all the water is pumped out.
If the dishwasher alarms out again and you still have water in the sump then make sure the pump is indeed running and the drain hose is free.
Let me know what you find.