How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Michael Your Own Question
Michael
Michael, Customer Service
Category: Appliance
Satisfied Customers: 9568
Experience:  I have been an appliance repair tech for over 30 years and will help you solve your problems.
11519491
Type Your Appliance Question Here...
Michael is online now

thorn olypic 20/35b boiler wont fire up- pump not running fitted

Customer Question

thorn olypic 20/35b boiler wont fire up- pump not running fitted new thermastat ranco c77po100 but power only goes to one pin no power to pump or gas valve
pilot light working
Submitted: 4 years ago.
Category: Appliance
Expert:  Michael replied 4 years ago.

 

Hi sorry to hear that.

What was the reason for the T stat change?

Also was it working before the replacement?

Thank you

Tech Michael

Customer: replied 4 years ago.

I replaced the T Stat because I thought that was the problem with the boiler not firing up. It had been fine it just suddenlry stopped working.

Expert:  Michael replied 4 years ago.

 

Thanks Bryan,

 

Please check to see if there is a rest button or switch or even at the main breaker on the main control at the boiler.

Please let me know, if not the main board has likely failed and will need to be replaced.

its not difficult and I will assist you with that if you need me. Also I can locate a good source for that if you don't have a local supplier for it;-)

But Since this question may continue for some time, if you will rate my service as good or better
before you close this window, the system here will allow me to schedule free follow ups with you
so your question wont close or time out and you can contact me anytime at no additional cost.
Thank you
Tech Michael

 

Customer: replied 4 years ago.

Thanks Michael, no there isn't any kind of rest button, or a circuit board. Its just a terminal block, with a six pin red pumped plug with connections to pins on T Stat.

Expert:  Michael replied 4 years ago.

 

Thanks Bryan, You will need a meter for this test.

If there is power at the main control should be a box or board with relays and various electronics on it (not the T Stat).

please let me know.

Thank you

Tech Michael

Customer: replied 4 years ago.

There is power to the main terminal block, then power through to one of the six pin red pump plugs, and then power to the number nine pin on t stat. There is no power at the pump or the gas valve connections.

Expert:  Michael replied 4 years ago.

 

Do you know where the main control board is?

Thanks

Tech Michael

Customer: replied 4 years ago.

I'm sorry I don't know what you mean by main control board. All there is is the mains power switch on the wall from a fused spare, which leads into an overidden programer, then the power goes into the terminal block which then goes into the t stat and then through to the pump. The loss of power occurs at the t stat where there is power going in but none coming from it.

Expert:  Michael replied 4 years ago.

 

Hi Bryan,

you can try to jump the power wire at the T stat, and see if it will work then,

If so the Tstat was wired wrong. If not there is a power loss elsewhere and it may be due to the programmer.

Keep me posted.

Thank you Tech Michael