How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Daniel Your Own Question
Daniel
Daniel, Home Appliance Technician
Category: Appliance
Satisfied Customers: 15979
Experience:  20+ yrs. experience in white goods repair. NVQ Level 2 electronics manufacturers training courses.
15468697
Type Your Appliance Question Here...
Daniel is online now

Whirlpool AWO/R 5026 washing machine. No lights on the panel.

Customer Question

Whirlpool AWO/R 5026 washing machine. No lights on the panel. no power. I have Checked socket power. fuse in plug. replaced door catch/switch. What else should I check.
Submitted: 3 years ago.
Category: Appliance
Expert:  Daniel replied 3 years ago.

Hi

 

If theres no power on the display and the mains power is fine then its either the mains filter at the back or the control board.

 

What you need to do is remove the top and look at the back on the right and you will see the mains filter there. It has the mains cable going into it then you will have another 2 wires coming out going to the control board. If you have a multimeter you can test to make sure you have 240v coming out of that mains filter.

 

If you do then the control board will be the fault here and will need to be replaced.

 

If you need anymore info just get back to me.

 

Regards

Customer: replied 3 years ago.

Hi Daniel


I did not have a test meter but used a lamp without a plug. power runs to the front board.


I have ordered a used front board/panel.


I will let you know how I get on (if the part arrives in time before I leave my sisters Friday)


Thanks for your techno reply


 

Expert:  Daniel replied 3 years ago.

Hi

 

Ok if theres power going to the control board then it looks like its faulty.

 

Fingers crossed the new part you get will cure this for you.

 

Regards

Related Appliance Questions