How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Michael Your Own Question
Michael
Michael, Customer Service
Category: Appliance
Satisfied Customers: 9568
Experience:  I have been an appliance repair tech for over 30 years and will help you solve your problems.
11519491
Type Your Appliance Question Here...
Michael is online now

Good Evening, My induction hob details: Electrolux type

Customer Question

Good Evening,

My induction hob details:

Electrolux type EHD 72100-X product XXXXXXXXX serial 7 17 03334

It has been workig for few years faultlessly then suddenly, a couple of days ago the kitchen fuse blew and I can't use the left hand 2 hotplates since.

There are no visible singns on the hob, I have checked the connections, are alright. I have cut supply , then the unit resets to normal. Once I switch it on is normal for few seconds then it displays E 5 E 5. then after antother cca 10 seconds the left 2 hotplaes are going E while I can use normally the right side ones.

Would anyone please suggest what could be wrong?

bregards

Alex
Submitted: 3 years ago.
Category: Appliance
Expert:  Anthony F. replied 3 years ago.

Anthony F. :

Sounds like your Inverter board for the left side needs replaced

Anthony F. :

I cant find a part listed anywhere

Anthony F. :

look for power board left

JACUSTOMER-x2n57h9a- :

Hi Anthony, Can I get any further details about the part I shall search for and any idea where to order it? Any clue as why happened?

JACUSTOMER-x2n57h9a- :

bregards

JACUSTOMER-x2n57h9a- :

Alex

Anthony F. :

the board supplies power to the induction hubs there are 2 of them

Anthony F. :

one for the left has failed

Anthony F. :

I have searched under your model and have not been able to find the part listed or what the part number is

Anthony F. :

suggest you contact the manufacturer

JACUSTOMER-x2n57h9a- :

I have already tried myself, no success though. It is clear for me that it's a power supply issue, I needed details though as to figure out how I can recover my hob. Thanks for your time and efforts.

Anthony F. :

Thanks for using JA there just is no information on this unit out there to give you sorry

Expert:  Michael replied 3 years ago.
Hi,

The suggested cure is to turn the power off for 10 seconds then switch back on.
If this doesn't cure it I'm afraid you are looking at replacing the electronics one part at a time to hopefully cure the fault. The most likely fault is either the filter or power boards.
The error message isn't very specific other than in the power supply section.

However, this would not really be an option. The power board, for the model provided is an astronomical £400 plus. (There are two power boards and one filter board in the appliance as well as the touch control board).

My advice on this one is to call Domestic and General (I'm assuming you are in the UK) and ask for a price for a repair and 1 year extended warranty, you'll get the details at www.domgen.com
I have seen this problem time and time again.
I will stick with you until we have this working and can also supply other sources for the parts you need if you want to go that route?
Since this question may continue for some time, if you will rate my service as good or better
before you close this window, the system here will allow me to schedule free follow ups with you
so your question won't close or time out and you can contact me anytime at no additional cost.
Thank you
Tech Michael