How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Michael Your Own Question
Michael
Michael, Customer Service
Category: Appliance
Satisfied Customers: 9568
Experience:  I have been an appliance repair tech for over 30 years and will help you solve your problems.
11519491
Type Your Appliance Question Here...
Michael is online now

how to fit a thermostat to a hover built in oven mod hdo 8

Customer Question

how to fit a thermostat to a hover built in oven mod hdo 885/1b
Submitted: 3 years ago.
Category: Appliance
Expert:  Michael replied 3 years ago.
Hello,
I am Tech Michael and I will be assisting you today.
Please be patient with us as these are technical questions and some testing may be required.
It may take a bit of back and forth conversation to be sure we have all the information in order to make a proper diagnosis.
Did you mean Hoover?
Also May I have full model #?
Thank you
Tech Michael
Customer: replied 3 years ago.

 


built in oven model hbo885/1b code 33700-09350104 thermostat for main oven hoover

Expert:  Michael replied 3 years ago.
Hi Dave, here is a video that explains that process. please let me know if this one will work for your oven it should.
I will stick with you until we have this done.
A word of warning, do not remove the wires until you have the new thermostat! Also label the wires if you need to, it would be a terrible mess if you forget where they go!
Since this may take some time, if you will rate me in a positive fashion before you close this page, the system will allow me to schedule free follow ups with you and also ensure your question will NOT close or time out;-)
You will then be able to contact me at anytime at no additional cost until we have this fixed for you.
Thank you
Tech Michael


http://www.youtube.com/watch?v=vTFbYfeIIeg