How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Michael Your Own Question
Michael
Michael, Customer Service
Category: Appliance
Satisfied Customers: 9563
Experience:  I have been an appliance repair tech for over 30 years and will help you solve your problems.
11519491
Type Your Appliance Question Here...
Michael is online now

I have a siemens surpresso S75 automatic coffee machine. It

Resolved Question:

I have a siemens surpresso S75 automatic coffee machine.
It is displaying the message "Fill Pipe System // Press Water"
I press water and water is dispensed for a short time. During this time the display reads "Filling Pipe System". The instruction book says that it may need several presses. I have repeated this well over a hundred times but the error will not clear?
Submitted: 3 years ago.
Category: Appliance
Expert:  Michael replied 3 years ago.

Hello,
How old is your coffee maker?
Also have you run a cleaning cycle recently? Descale?
Thank you
Tech Michael
Customer: replied 3 years ago.

Hi


The machine is about 5 years old. I have recently run a cleaning cycle but it has been a while since it required a descale.
I always run the cycles as they are requested.


 

Expert:  Michael replied 3 years ago.
Thanks Tony, the error you are getting(on a reg basis) occurs when your system is in need of descaling or the main control has failed.
When you descale what do you add to the machine?
Thank you
Tech Michael

Customer: replied 3 years ago.

I use the descaling fluid from Siemens exactly as per the instructions.
How do I get the machine to run a descaling cycle if it doesn't ask for one?


Thamks

Expert:  Michael replied 3 years ago.
Hi Tony, you can simply use the cleaning liquid, but let it sit in the unit for a few hours to see if it will clean the residue off the pipes and sensors this time. You may live in a hard water area and that will cause this.
If this doesn't help then unfortunately the unit will require service as it will need likely new sensors.
Let the cleaner sit then flush it through as many times as needed.
I will stick with you until we have this sorted out one way or the other but
since this may take some time, if you will rate my service in a positive fashion thus far before you close this page, the system will allow me to schedule free follow ups with you and also ensure your question will NOT close or time out;-)
You will then be able to contact me at anytime at no additional cost until we have this fixed for you.

Thank you Tony.
Tech Michael
Michael and other Appliance Specialists are ready to help you

Related Appliance Questions