How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Daniel Your Own Question
Daniel
Daniel, Home Appliance Technician
Category: Appliance
Satisfied Customers: 15962
Experience:  20+ yrs. experience in white goods repair. NVQ Level 2 electronics manufacturers training courses.
15468697
Type Your Appliance Question Here...
Daniel is online now

Hi there. I have a belling IDW604. Its 7 years old, and it

Resolved Question:

Hi there.
I have a belling IDW604.
Its 7 years old, and it has been a great machine.
Its never caused an issue but today the buttons seem a little non responsive.
It will power up, however it will not allow me to select a program.
There seems to be a faint light on behind the program lights, but no error message
Submitted: 3 years ago.
Category: Appliance
Expert:  Daniel replied 3 years ago.

Hi

 

Is anything coming up on the display on the left hand side of the panel?

 

Also have you tried holding the programme button in and then turn the dishwasher on and keep both on/off button and programme button held in for about 10 seconds to see this does anything?

 

Regards

Customer: replied 3 years ago.

The display on the left hand side shows:


00


 


Yes, I have tried the programme and power buttons simultaneously.
Nothing happens.

Expert:  Daniel replied 3 years ago.

Hi

 

Ok that's fine. Have you tried removing the plug from the socket and leaving it for 20 mins as this can sometimes reset the electronics.

 

If its still the same then remove the wooden door and from there remove the plastic control panel. There you will see 2 control boards. One on the left with the screen and the other is the programing board. Check the wiring connections to there is fine.

Disconnect the wire and refit it a few times and then see if this gets it going.

 

If its still the same then im afraid its a faulty control board and will need to be replaced. Now when you get the new board it will come with the main board on the left and the programing board and the wiring. It comes complete so just a case of swapping over.

 

If you want the part number for the control board its###-##-####/p>

 

But just check the wiring in case it poor connections but if that's fine then its looking like a faulty control board.

 

Regards

Daniel and other Appliance Specialists are ready to help you

Related Appliance Questions