How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Daniel Your Own Question
Daniel
Daniel, Home Appliance Technician
Category: Appliance
Satisfied Customers: 16551
Experience:  20+ yrs. experience in white goods repair. NVQ Level 2 electronics manufacturers training courses.
15468697
Type Your Appliance Question Here...
Daniel is online now

I have a Flavel Milano E60, everything works fine except for

Resolved Question:

I have a Flavel Milano E60, everything works fine except for the oven suddenly stopped heating up. I've changed the element thinking that was the problem as everything else works ok but still no heat. I look forward to some expert advice.
Submitted: 3 years ago.
Category: Appliance
Expert:  Daniel replied 3 years ago.

Hi

 

Can you post the full model number please.

 

Also is it a fan assist oven?

If so is the fan running?

Does the little red light come on the front panel when you turn the oven on?

 

Regards

Customer: replied 3 years ago.
Yes it is fan assisted which is still running and yes the red light still comes on when turned on. Where would I find the full model number .
Expert:  Daniel replied 3 years ago.

Hi

 

The model number is ***** a sticker at the bottom of the main oven. Open the oven door and its at the bottom there.

 

Also just checking it was the round fan element you replaced?

 

Regards

Customer: replied 3 years ago.
Sorry there doesn't appear to be a sticker on the oven, just one on the back with a bar code and the code ML6CDW. Yes it was the round fan element I replaced.

Many thanks
Expert:  Daniel replied 3 years ago.

Hi

 

That's it thanks.

 

If you have replaced the element and the little light is coming on then the thermostat is fine.

Its more then likely the thermal cut out stat on the back.

If you remove the back panel and look to the right in the bottom oven cavity you will see a small thermostat with 2 wires going to it. You need to test this with a multi meter and see if faulty. If it is then the thermal cut out is faulty and will need to be replaced.

 

Check that out and see what you find and let me know.

 

Regards

Daniel and other Appliance Specialists are ready to help you