How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Techdesk Your Own Question
Techdesk
Techdesk, Service Engineer
Category: Appliance
Satisfied Customers: 16409
Experience:  Whitegoods engineer working for a multibranded national company in the UK
13782322
Type Your Appliance Question Here...
Techdesk is online now

Whirlpool AWO3751 - Clean pump light is on. We have removed

Customer Question

Whirlpool AWO3751 - Clean pump light is on. We have removed the filter at the bottom right of the machine which is clear. The water which came out smells very badly. Where is the pump and how do I remove/clean it?
Submitted: 3 years ago.
Category: Appliance
Expert:  Techdesk replied 3 years ago.
Hiya,
The pump and filter chamber are one unit.

Where you took the filter out of houses the pump.

To access it, you need the front of the machine off.

However, the fault is more likely to lie in the pressure tube and pressure chamber.

Would you be able to take the machine apart to work on it?
You will need sockets and torx screwdrivers.

Thanks
Customer: replied 3 years ago.


Yes, I am happy to take the machine apart


 

Expert:  Techdesk replied 3 years ago.
Hiya,
OK, thanks for that.

Unplug the appliance.
Take the plastic cover below the front panel off.
Take out the screws holding the front panel.
Open the door.
Take the retaining ring out of the door seal.
Peel the seal off of the front panel.
Take the screws out of the door lock.
Push the front panel down and lift it off.
(bit awkward though).

Once off, you can access the pump and you'll see the thin tube coming off of the filter housing up to a pressure switch.
Take the tube off of the pressure switch.
Blow down the tube into the filter housing to move any gunge in there.

If you want to clean out the hoses and pump, you need to disconnect them and take them out.

Reassemble and try the machine again.

Hope this helps
Let me know if you need more help.
Thanks

Related Appliance Questions