How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Daniel Your Own Question
Daniel
Daniel, Home Appliance Technician
Category: Appliance
Satisfied Customers: 15991
Experience:  20+ yrs. experience in white goods repair. NVQ Level 2 electronics manufacturers training courses.
15468697
Type Your Appliance Question Here...
Daniel is online now

have a beko wm5120w wont go onto wash cycle all it does is

Customer Question

have a beko wm5120w wont go onto wash cycle all it does is drain, have just put in a new pcb can you help
Submitted: 2 years ago.
Category: Appliance
Expert:  Daniel replied 2 years ago.
Hi

If you set the washer going on a wash cycle does the door lock and then is it just sitting there doing nothing?

Regards
Customer: replied 2 years ago.

yes door locks then starts by empting , pump runs as if at end of cycle then lights go off and a further 3 mins the door unlocks

Expert:  Daniel replied 2 years ago.
Hi

Ok might be worth checking the carbon brushes in the motor first.

Lean the washer backwards against a wall and get someone to hold for you.
Then lay down and look under the washer. There you will see the back of the motor. At the back of the motor either side are the carbon brushes. Take these out and inspect them. See if they have worn down. If so then you need to replace them and see how it goes from there.

As on these if the carbon brushes are worn then it wont allow the washer to start and you get strange faults like this.

So check them and see what you find and let me know.

Regards
Customer: replied 2 years ago.

bushes are ok just started again emptied then a 3 second burst of water and then emptied and then door unlock

Expert:  Daniel replied 2 years ago.
Hi

Ok what happens if you set it to a spin only?
Will itturn the drum?

Regards
Customer: replied 2 years ago.

no spin even when dial set to spin all it did was pump came on even with no water in machine and keept going for a few mins then end and door unlocked

Expert:  Daniel replied 2 years ago.
Hi

Ok try this and see what happens.

Turn the dial to cottons 90 deg which should be 12 oclock position.
Then turn the washer off.
Then press and hold the start button and keep it held in.
Then turn the washer on and keep the start button held in for several seconds then let go.

Now press the start button 4 times and see if the drum starts to turn.
Then press start again and it should turn again.
Press again and it should spin.
Press again and it should fill with water.

Try that and see if any of this works and let me know.

Regards
Customer: replied 2 years ago.

no none of the above worked the drum did not turn and didnt fill with water

Expert:  Daniel replied 2 years ago.
Hi

Ok im taking it its the same fault as before you replaced the control board?

Try this and see what happens. Disconnect the wiring block to the motor and then retry the washer on a wash cycle and see if it will kick in and start washing.

If not then locate the pressure switch on the top on the right at the front. Remove the thin hose form the bottom of it and blow hard down it and then retry it and see what happens.

Regards
Customer: replied 2 years ago.

wiring block removed from motor didnt start a wash cycle blew down pipe on preasure switch started to fill with water for a few seconds and then emptied

Expert:  Daniel replied 2 years ago.
Hi

Ok as you can see there isnt a lot in these washer. Theres a control board, motor, heater pump, water valves and a pressure switch.

Now the heater, pump and water valves wont cause this fault.
As the pcb is new we can rule that out so the fault is more then likely the motor or the pressure switch.

As the brushes are fine and disconnecting it did do anything different then the motor is looking ok.
So as to the pressure switch these are electronic pressure switches so if they fail they can cause it to not start at all . So as you disconnected the hose and if did start to fill but then stop its looking like the pressure switch itself is the fault here. Just check the wiring going to the switch and make sure thats fine but if it is thenits looking like a faulty pressure switch here.

Regards
Daniel, Home Appliance Technician
Category: Appliance
Satisfied Customers: 15991
Experience: 20+ yrs. experience in white goods repair. NVQ Level 2 electronics manufacturers training courses.
Daniel and 2 other Appliance Specialists are ready to help you
Expert:  George-Allsorts replied 2 years ago.
Disconnect the positive and neutral cables from the heater element and try the washer with them disconnected. If your heater has an earth leak this is one of the faults that it will produce.
Expert:  George-Allsorts replied 2 years ago.
Did you find which one was causing the problem?