How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Andrew Smith Your Own Question
Andrew Smith
Andrew Smith, Home Appliance Technician
Category: Appliance
Satisfied Customers: 3629
Experience:  Gas cooker specialist
46681511
Type Your Appliance Question Here...
Andrew Smith is online now

I have an ecoTec combi boiler with an Altech thermost. Needed

Customer Question

I have an ecoTec combi boiler with an Altech thermost. Needed to change thermostat batteries and now cannot get heating to work. Hot water is ok and all appears to be working. Just no heat. Help, please.
Submitted: 2 years ago.
Category: Appliance
Expert:  Andrew Smith replied 2 years ago.
***** ***** : Are you able to take the thermostat off the wall and place under the boiler?
JACUSTOMER-jhnl8fy3- :

Yes, tried that

***** ***** : Ok, if you leave it under the boiler
***** ***** : Turn off the power to the boiler and ensure the lights go out
***** ***** : Take the batteries out of the transmitter
***** ***** : Leave for 5 minutes
***** ***** : Turn the power back on
***** ***** : Insert the batteries
***** ***** : After about 30 seconds the two units should resync
JACUSTOMER-jhnl8fy3- :

Look p.m.

***** ***** : If that has not worked then the thermostat must be faulty, but before we attempt to wire around it - can you confirm the pressure is around 1.5bar and there are no fault lights or error codes on the boiler?
JACUSTOMER-jhnl8fy3- :

Only got half your message; have managed to retrieve all instuctions and are currently waiting the required 5 mins!

***** ***** : No problem - let me how you get on, it should work.
***** ***** : If not, then we will move onto another stage
JACUSTOMER-jhnl8fy3- :

OK tried that twice. Little flame on thermostat flashing. Red and green lights on on receiver, but no noise from boiler, and still no heat to rads

JACUSTOMER-jhnl8fy3- :

Pressure ok, no error messages, just temp. 51° on little screen.

***** ***** : Ok, I can get you heat if you need it
***** ***** : You will need to take the cover off the receiver and tell me the cables and connections