How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Michael Your Own Question
Michael
Michael, Customer Service
Category: Appliance
Satisfied Customers: 9568
Experience:  I have been an appliance repair tech for over 30 years and will help you solve your problems.
11519491
Type Your Appliance Question Here...
Michael is online now

Hi, I have a Worcester Heatslave 20/25 oil-fired combi

Customer Question

Hi,
I have a Worcester Heatslave 20/25 oil-fired combi boiler. The hot water part of it works fine, but when the heating switches on (either by timer or manual switching on) the boiler doesn't fire.
I've found that a good smack on the side at the top front left corner makes it work instantly, but that isn't much good now I wanting coming on while we're out/in bed.
Happy to pay for any answer, even if it's just "get an engineer out now" as this will get it fixed quickly.
Thanks in advance!
Dave
Submitted: 3 years ago.
Category: Appliance
Expert:  Michael replied 3 years ago.
Hi, this is a bad controller or simply a loose wire on the unit.
My suggestion to you would be to re tighten the connections to the control at the boiler. If that works GREAT! But if it doesn't, then you have a failing relay on the board more than likely.
I will stick with you until this is fixed, please don't forget to rate my service to you before you close this page. I will be available to you at no additional cost , you can then get in touch with me anytime by simply replying to this message.
Thank you and have a great day!
Tech Michael
Michael and other Appliance Specialists are ready to help you
Customer: replied 3 years ago.

Hi Michael,

Thanks for the reply. Please can you describe where in the boiler I should be looking for/tightening connections. I haven't been inside it yet, so would appreciate a pointer where to start.

Thanks!

Expert:  Michael replied 3 years ago.
Hi Dave, you want to look at the control box, its basically a relay device. Its where you would likely see a light(LED).
Its more than likely going to need to be replaced, but it could be a loose wire as that would cause exactly what you describe.