How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dales-Electronic Your Own Question
Dales-Electronic
Dales-Electronic, Home Appliance Technician
Category: Appliance
Satisfied Customers: 1466
Experience:  I am a Home Appliance / Refrigeration Technician of 25yrs+ with my own business and for multi-brand national companies.
26760916
Type Your Appliance Question Here...
Dales-Electronic is online now

hi i have an amana SBDE522vw have had to take of door to install

Resolved Question:

hi i have an amana SBDE522vw have had to take of door to install new panels have plugged all wires back as they were but nothing is working on control panel on front of fridge and freezer are working as well as internal lights any ideas ?
Submitted: 2 years ago.
Category: Appliance
Expert:  Dales-Electronic replied 2 years ago.
Dales-Electronic :

Hello My name is Ian ~ I am not on the site constantly so please be patient whilst waiting for responses to you queries

Dales-Electronic :

OK can I assume in taking off the doors you had the power switched off? If so the first thing I would do is take off the top hinge cover and check that the plug in pins have actually located in their matching sockets and that you have them all connected the correct way around (I know they are latched but it is possible to get them the wrong way around) sometimes when you push them together one of the pins gets dislodged. Secondly, these commonly break a wire at this point so check that all wires are intact. Logically, since is the only area that you have moved the fault likely is at this point - Ian

Customer:

have checked pins all connected mike

Dales-Electronic :

OK Mike did you have it connected to the power when you disconnected the hinge connectors?

Customer:

no unplugged

Dales-Electronic :

OK just to reiterate have we got nothing at all working at all?

Customer:

freezer and internal light ok water and ice cubes ok fridge seems ok and internal light but have no lights / temp control /holiday mode etc on front panel

Dales-Electronic :

OK that makes more sense, from what you say, you have either got a dodgy display board that has just given up the ghost or somewhere between the top connectors and the display board you have a broken cable. You will need to check out the continuity between hinge connectors and facia with a multimeter or get someone to do that for you, if they are sound then the board is faulty ~ Ian

Customer:

ok not sure if frigde was unplugged when door connection was unplugged wasnt myself fitting new panels would this make a difference ?

Dales-Electronic :

Yes, if they tried to connect one of the top connectors the wrong way around or alternatively shorted out the cables this could have destroyed one of the boards ~ Ian

Dales-Electronic :

Would you now kindly rate my service to you ~ this allows the system to close down the call, you can continue to chat to me an no extra charge once this has been done ~ Good luck ~ Ian

Dales-Electronic and other Appliance Specialists are ready to help you