How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Rob Your Own Question
Rob
Rob, Home Appliance Technician
Category: Appliance
Satisfied Customers: 6991
Experience:  20 yrs. experience with a major worldwide manufacturer.
14831508
Type Your Appliance Question Here...
Rob is online now

Teka dishwasher DW6 - 55 both lights (salt and rinse aid)

Resolved Question:

Teka dishwasher DW6 - 55
both lights (salt and rinse aid) are constantly on. no beeps, or reaction if i press the program button (if i press the reset 'hold' P for 5 secs nothing, if i press the P and the power it shorts the whole kitchen
got a rougue trader in who told me intially to add salt and rinse aid, then i explained that i'm fairly confident it's to do with the cycle timer,he then advise me to buy a power module for £300
Am i looking at buying a new dishwasher? please help
Submitted: 3 years ago.
Category: Appliance
Expert:  Rob replied 3 years ago.
Welcome, my name is ***** ***** I will be helping you with your problem today. If anything isn't clear, please just ask me.

When you try to select a new cycle, do you hear a pump running?
Any error codes or flashing lights? Othere than the rinse aid and salt

Thanks
Rob

PS, how old is this?
Customer: replied 3 years ago.

about 6/7 years old, but only used in the last 18 months (previous occupant had never used it)

Expert:  Rob replied 3 years ago.
Hi

Thanks
and the other questions?

Rob
Customer: replied 3 years ago.

Sorry Rob, no pump sound, lights are continually on (just salt and rinse aid) no beeps etc

i tried to flood the base, so that it would drain (have had a rinse issue before) but it seems to have stalled?

Expert:  Rob replied 3 years ago.
Hi

Thanks

OK, this is, as you suspect, a main board issue

Turn off the power,
Remove the screws around the door.
The front part of the door will come away, leaving the inner door and all the electricals in place

Look carefully at all the connectors, wiring and components.
You may be lucky and have a bad or loose connection.
If you see burn marks on the main board, its almost certainly not worth repairing as parts are so expensive on this. Also, even though you may not have used this a lot, it will soon be approaching the time when some of these parts will become increasing difficult/impossible to find

Hopefully you will find a loose connection

If you need more help, please just ask.
In the meantime,

Can I ask you to take a moment and rate my responses so far? Please use the smiley faces which you should now see. Please remember you are rating me personally, not the website or the problems you have had with this machine.
This will not close your question and you can still come back to me if you need more help
Thanks
Rob

Rob and other Appliance Specialists are ready to help you
Customer: replied 3 years ago.

Thanks Rob, wish i came to you first, have a good day

Expert:  Rob replied 3 years ago.
Hi Dunc

Thanks , and your welcome
Please dont forget to rate as this is the only way I get credit for helping you

All the best
Rob