How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dales-Electronic Your Own Question
Dales-Electronic
Dales-Electronic, Home Appliance Technician
Category: Appliance
Satisfied Customers: 1464
Experience:  I am a Home Appliance / Refrigeration Technician of 25yrs+ with my own business and for multi-brand national companies.
26760916
Type Your Appliance Question Here...
Dales-Electronic is online now

Hi - I have a fault with a Fagor induction hob (IF-900S), 90cm

Customer Question

Hi - I have a fault with a Fagor induction hob (IF-900S), 90cm 5 rings. The centre 2 no longer operate.
These are powered via a separate plug to the other 3.
Checked fuses and power sockets already.
suspect a a faulty part somewhere. Hob is 3 years old.
any ideas?
Submitted: 2 years ago.
Category: Appliance
Expert:  Dales-Electronic replied 2 years ago.
Dales-Electronic :

Hello My name is Ian ~ I am not on the site constantly so please be patient whilst waiting for responses to you queries

Dales-Electronic :

Almost sure to be a power board fault ~ hang on and I will see if I can find the part number and price for you.

Dales-Electronic :

Can you recheck the model number please I can only find the IF900S1, S2, S3, S4, S5 & S6 you may have to take a torch and look under the hob itself for the full details ~ Ian

JACUSTOMER-gyjqf34b- :

i can't get to it but all the paperwork specifies it as IF-900S. I expect this is the original and the S1,S2, S3 all followed. Would this be the part:

JACUSTOMER-gyjqf34b- :

http://www.partmaster.co.uk/fagor/if-900s/power-card/product.pl?pid=3726919&path=78825,61224:216730&model_ref=1258003

Dales-Electronic :

What you will have to do is look on the board itself as there are two ~ once you have the one that is connected to the non working rings then that's your part. One major problem you may have is that Fagor has gone bust and you may not be able to get the one you want ~ I have tried Connect Distribution the largest parts supplier and Qualtex the next largest and neither have any stock at all. If you can give me until tomorrow I will find out the correct part number for you and come back to you in the evening, these boards are alittle pricey to have the wrong one delivered ~ Ian

JACUSTOMER-gyjqf34b- :

Its printed underneath the appliance with IF-900S. But I now have some new information. It was some time ago that i last tested the plug sockets. Looking again, it is NOT the case that the non-working rings are on one circuit and the the working are on the other. 2 of the working rings (left of the appliance) are clearly connected to one plug. The 3rd working one (on right) is connected to the other plug. And the 2 non-working (middle 2)? well they must connect with either of the others - i expect to the 2 left ones given that the right one is a higher power to the other 4? (that's just my logic). If that's the case, maybe its not a complete power card that is faulty but something else or a component(s) on the power card...?

Dales-Electronic :

OK I understand your logic, the problem is that there is no test to test out the hotplates so it is done by substitution, the problem that you are going to have here is that having gone bust parts for Fagor are getting thin on the ground and technical info even more so, I cant at this time get a wiring diagram or illustrated parts list ~ the hotplates that are not working, are they the same size as those that are?

Related Appliance Questions