How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask KevinWhiteJA Your Own Question
KevinWhiteJA
KevinWhiteJA, Home Appliance Technician
Category: Appliance
Satisfied Customers: 997
Experience:  Worked on appliances for more than 15 years
70193065
Type Your Appliance Question Here...
KevinWhiteJA is online now

My Induction Hob is showing a fault with the small ring at

Resolved Question:

My Induction Hob is showing a fault with the small ring at the front of the unit.It turns on alright but after a few seconds the digital number that was set goes to part of the number showing and looses heat.All the other rings are fine and all my pots etc. are for induction,the appliance is 3yrs old.
Submitted: 2 years ago.
Category: Appliance
Expert:  KevinWhiteJA replied 2 years ago.
KevinWhiteJA :

Hi, welcome to Just answer

KevinWhiteJA :

Please tell me its complete model number

Customer:

New World EL160 Induction Hob

KevinWhiteJA :

OK, all other rings works fine and it is just this small ring causing the problem

Customer:

yes

KevinWhiteJA :

OK, as the other three work perfectly fine it looks more like a control module fault...you can take the hob out and then take the top off and check the wiring from this ring to the control...if it appears fine then it is the control, it can be the element as well but then it wont even start

Customer:

I have looked at the handbook and the half of the digital reading is actually a U,sorry for misleading you.

KevinWhiteJA :

sorry I dont understand... half of the digital reading is actually a U ?

Customer:

yes and it flashes on and off the same as when a pot is removed

Customer:

My wife tells me that this fault appeared when she was using that ring and then seemed to be working Ok till this morning

KevinWhiteJA :

Alright it is more likely a loose wiring or the control module... please take the hob out and then check the wiring

Customer:

i will take the hob out and if it,s not a loose wire i will have an electrician from Currys check it out. thanks for your assistance

KevinWhiteJA and other Appliance Specialists are ready to help you