How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Michael Your Own Question
Michael
Michael, Customer Service
Category: Appliance
Satisfied Customers: 9562
Experience:  I have been an appliance repair tech for over 30 years and will help you solve your problems.
11519491
Type Your Appliance Question Here...
Michael is online now

newera pph1000. sometimes it works then it can go days not

Resolved Question:

newera pph1000. sometimes it works then it can go days not working and then days working fine. not worked now for 5 days
Submitted: 2 years ago.
Category: Appliance
Expert:  Michael replied 2 years ago.
Hi there are a few different items with the same model #.
Please describe the exact model, it looks like your heater is that correct?
Also how old is the unit?
Please be detailed with the description so I can help you effectively;-)
Thank you
Tech Michael
Customer: replied 2 years ago.

It is a creda newera panel heater pph1000 approx 9 years old but only used infrequently

Expert:  Michael replied 2 years ago.
Thanks for the explanation;-)
Is yours the gas or electric model?
Thank you
Tech Michael
Customer: replied 2 years ago.

electric (didn't know there was a gas version sorry!)

Expert:  Michael replied 2 years ago.
Lol, thats ok Steve,
when it doesn't work what does it do exactly? any sign of life etc?
Thank you
Tech Michael
Customer: replied 2 years ago.

It sometimes comes on and works fine. sometimes just nothing at all. sometimes put it on and nothing happens but when left on may come on some time later (could be hours later). It's the equivalent of a loose connection which decides when it feels like connecting. there is no pattern i.e. days or times when it does or doesn't work

Expert:  Michael replied 2 years ago.
Hi thanks Steve, yes you are exactly correct.
It is likely a bad thermostat, but it could also be simply a loose connection on one of the push on wire clips. The best thing to do is clean and inspect the connections. By disconnecting each wire then re connecting it that should sufficiently clear this issue.
Also if you come across a loose clip, you can squeeze it tight a bit with a pair of needle nose pliers;-)
Let me know how this goes. I will stick with you until this is fixed, please don’t forget to rate my service to you before you close this page. I will be available to you at no additional cost , you can then get in touch with me anytime by simply replying to this message.
Thank you and have a great weekend I will be here most of the weekend as well if you need me!
Tech Michael
Michael and other Appliance Specialists are ready to help you

Related Appliance Questions