How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dales-Electronic Your Own Question
Dales-Electronic
Dales-Electronic, Home Appliance Technician
Category: Appliance
Satisfied Customers: 1466
Experience:  I am a Home Appliance / Refrigeration Technician of 25yrs+ with my own business and for multi-brand national companies.
26760916
Type Your Appliance Question Here...
Dales-Electronic is online now

We have a Sierra Spa hot tub with Hydro Quip components we

Customer Question

We have a Sierra Spa hot tub with Hydro Quip components we get the fault code FLC appears after approx 30 minutes which cuts out the heater. The circulation pump has been replaced together with new filter, new flow switch, new high limit sensor.
When FLC is displayed and I turn the tub off and on it clears the fault code but after approx 30mins the same problem occurs.
Other Forums state that the pressure switch is at fault my tub appears not to have one. The heater is "U" shaped and 1 inch diameter labelled "Lang". Could it be that after Approx 30 mins it goes into filtration mode and triggers FLC and why?
Submitted: 2 years ago.
Category: Appliance
Expert:  Plumberpro replied 2 years ago.
Hi , are all your jets open? If not open all the jests up fully and try again
Customer: replied 2 years ago.
Yes the jets are all open. I have tried that and all air has been purged from the tub.
Expert:  Plumberpro replied 2 years ago.

You may have a blockage of debris somewhere. Also check the valve is fully open even if the handle looks as if it is

Expert:  Plumberpro replied 2 years ago.
If you can take off any hoses as well to inspect for blockages , scum build up
Customer: replied 2 years ago.
All valves were checked when we replaced the circulation pump we checked the impella for damage and blockages and there were none. With the new circulation pump there is very good circulation of water. To gain access to all the pipe work and fittings would mean dismantling most of the hot tub which is made of wood paneling and would be pretty drastic if this is not the cause. Could it be a PCB problem
I do not know who to turn to next?
Expert:  Plumberpro replied 2 years ago.
Could be PCB. You have tried everything else.
Customer: replied 2 years ago.
I am a builder with plumbing knowledge and all that you have suggested I had already tried. I wanted a Hot Tub Specialist.
Expert:  Dales-Electronic replied 2 years ago.
Hello My name is Ian ~ I am not on the site constantly so please be patient whilst waiting for responses to you queries ~ can you give me the details on the Hydro~Quip rating plate and I will see if I can help you.
Customer: replied 2 years ago.
The tub is at our holiday home and we have come back now
I can advise you that the tub is either a 900 or 9000 model with twin pumps . Have you read the previous emails on the problem and my previous answers?
Expert:  Dales-Electronic replied 2 years ago.
Yes I have but without the necessary information it will be difficult to help you out as there are a number of versions of both pcbs and components fitted to the Sierra Spa depending upon the clients requirements. If you could get me the details I should be able to help you further, guessing at this stage will likely end up with you spending monies on replacing components that are not faulty ~ Ian
Customer: replied 2 years ago.
Thank you I will contact my neighbour to go in to have a look at the tub and will come back to you.
Expert:  Dales-Electronic replied 2 years ago.
No worries, look forward to it, have a great evening ~ Ian
Customer: replied 2 years ago.
Hi Ian our neighbour has advised us that the model is COROMANA(###) ###-####and he thinks the PCB ref is WD4428. Does this make sense.
Many Thanks
Expert:  Dales-Electronic replied 2 years ago.
Hows about Corona CA this is the place in California that the thing is made !! The label looks like this ~~ http://www.hotwatercontrols.com/wiring.html ~~
Customer: replied 2 years ago.
Hi Ian
Apologies for the late reply as we have been away with the grandchildren!
We have an engineer looking at the tub on 1st June. This is the only day we could get access as we rent the property out. I would say he has a good knowledge of hot tubs and he is familiar with our one. However I don't think he has the caberbilities regarding the PCB board etc.
We did put in the wiring diagram number and then could not get a read out. You seem to be leading towards an electronic fault rather mechanical. Is there any advice or guidance we could relay to the engineer or details you may require or photographs to assist you.
Many Thanks Keith
Expert:  Dales-Electronic replied 2 years ago.

A photo of the rating plate would be helpful if you could get it to me ~ Ian