How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask George-Allsorts Your Own Question
George-Allsorts
George-Allsorts, Senior Appliance Technicial Manager
Category: Appliance
Satisfied Customers: 1448
Experience:  A whitegoods technician with 30+ years service in Domestic Appliance Service & Repair, and General Mechanical & Electrical Repair
19471162
Type Your Appliance Question Here...
George-Allsorts is online now

I have a Siemens extraklasse xl1400 washing machine. All the

Resolved Question:

I have a Siemens extraklasse xl1400 washing machine. All the lights on the front have come on, & nothing is working. Local repair man thinks it may be the motor, but until we can reset the board we won't be able to fix it. how do we reset the board?
Submitted: 2 years ago.
Category: Appliance
Expert:  Michael replied 2 years ago.
Hi Im sorry to hear about that. Your repair tech is partially correct the board is the problem. But there is no reset other than this, unplug the washer and wait 1 hour. Then press and hold the power button in for about 20 seconds then release it.Now you can plug the washer in and let me know if it resets or its still locked up the way it is now.If this fixes the problem, please rate kindly but if not, pleas do not rate my service yet but simply reply to me for further information on this problem.Thank youtech Michael
Expert:  George-Allsorts replied 2 years ago.
Hello, my name is George..

Disconnect all loads from the mainboard in turn one by one testing the appliance each time until the fault is found, if the board operates at any given point, reconnect the latest load that was disconnected, if the board then doesn't operate, there is a component fault at the load you reconnected. ...

If the board does not operate after disconnection of all loads, you have a fault in the board itself

Kindly be patient whilst awaiting any responses from me as I'm not constantly available.
George-Allsorts, Senior Appliance Technicial Manager
Category: Appliance
Satisfied Customers: 1448
Experience: A whitegoods technician with 30+ years service in Domestic Appliance Service & Repair, and General Mechanical & Electrical Repair
George-Allsorts and other Appliance Specialists are ready to help you
Customer: replied 2 years ago.

Tried what you suggested Michael twice. Unfortunately it hasn't made any difference at all. Every single light on the front is on and just stays exactly the same.

Expert:  George-Allsorts replied 2 years ago.

Ring my works number to discuss this #07787182156

Expert:  George-Allsorts replied 2 years ago.
How are you getting on with the problem Catherine?
Customer: replied 2 years ago.

Hi George, Sorry to be so long. Tried all your suggestions, but it's no better, so bit the bullet and called Siemens. Circuit board & motor gone, so not worth repairing, but thanks for all your help anyway.

Cath