How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Daniel Your Own Question
Daniel
Daniel, Home Appliance Technician
Category: Appliance
Satisfied Customers: 16330
Experience:  20+ yrs. experience in white goods repair. NVQ Level 2 electronics manufacturers training courses.
15468697
Type Your Appliance Question Here...
Daniel is online now

I have a hotpoint aquarius fdm 554 dishwasher that seems to have a problem. the two red

Customer Question

hi i have a hotpoint aquarius fdm 554 dishwasher that seems to have a problem. the two red lights on the left near the power button are on permanantly on. i start up a cycle and it pumps some water in for about a minute then empties it followed by ALL lights on machine flashing. any ideas?
Submitted: 1 year ago.
Category: Appliance
Expert:  Daniel replied 1 year ago.
Hi
Are you sure its all ligths flashing?
If you look at the 4 lights on the far right which are the wash, dry, end and start light.
When it fails certain lights should be flashing but all of them shouldnt. Can you double check them and see what you find please.
Regards
Customer: replied 1 year ago.
Hi yes all lights on machine are flashing well at least the three on right wash dry and end which are an orange colour and the two on left below power button which are red.
Customer: replied 1 year ago.
Basically I have removed this from a rental property when we sold it. I don't really know it's history however it is gleaming inside and out. It is currently in my garage where I am troubleshooting it. I sold it on eBay but had it returned due to said fault. Thanks
Customer: replied 1 year ago.
I can send a picture of lights if that may help
Expert:  Daniel replied 1 year ago.
Hi
Ok that makes sense as if you have the end 3 lights flashing but not the start light then that is an error code.
The error code its reporting is a turbin sensor fault.
This is a flow sensor in the plastic filling tank. So as water fills the tank it passes the through the flow sensor into the tank and the sensor sends the signal to the control of the amount of water that passes it.
If this fails then you get this fault were it starts to fill then it error codes out as the control board isnt getting the correct signal from the flow sensor.
Now most of the time for this fault is the flow sensor which comes as part of the filling tank.
If you pull the dishwasher out and remove the top and the left hand side panel there you will see the plastic filling tank.
Towards the bottom of that is the sensor. Check the wiring block there and disconnect it and reconnect it a few times and retry it and see how it goes from there.
If its still the same then you need to replace the filling tank and hopefully that will cure it from there.
But if that doesnt work then its the control board at the bottom.
But thats why its playing up like this as its reporting a filling issue with the dishwasher.
If you need anymore info just get back to me.
Regards
Customer: replied 1 year ago.
Thanks for your help I shall investigate tomorrow. After searching Internet I get the impression this isn't a popular model. Is this true? Can you advise where to get parts from? Many thanks. Very impressed with the quick reply.
Expert:  Daniel replied 1 year ago.
It is quite a popular model as we do see these out in the field still.

As to getting spares you can get them from either Hotpoint direct or www.4hotpoint.co.uk as they will stock the parts for these models.

Regards