How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask George-Allsorts Your Own Question
George-Allsorts
George-Allsorts, Senior Appliance Technicial Manager
Category: Appliance
Satisfied Customers: 1448
Experience:  A whitegoods technician with 30+ years service in Domestic Appliance Service & Repair, and General Mechanical & Electrical Repair
19471162
Type Your Appliance Question Here...
George-Allsorts is online now

We have a Bosch HBA13B150B built in oven. We have had it

Resolved Question:

Hi. We have a Bosch HBA13B150B built in oven. We have had it for about 7 years. It has been very reliable. This week it stopped working. It sounds like the fan is working and the grill works. But when we set the oven temperature it blows luke warm at best. The model number is ***** printed on our documents that came with it but it looks identical to the above modl seen on line.
Thanks
Submitted: 1 year ago.
Category: Appliance
Expert:  George-Allsorts replied 1 year ago.
Hello, my name is George..
This will be due to either the thermostat not working correctly, or the element failing..
Can you tell me if this is happening on just one program setting or on more than one?
Kindly be patient whilst awaiting any responses from me as I'm not constantly available.
Customer: replied 1 year ago.
Hi George
I only ever use the oven/fan setting and the fan/grill setting. Having just selected the other two settings they seem to be working. So on the fan/oven setting the best we get is lukewarm or cold air while the grill setting works fine with the upper element or is that the only element?
Expert:  George-Allsorts replied 1 year ago.
As the other two settings use the same thermostat as the fan setting, the fault will therefore lie with the ring element surrounding the fan that is used for the fan settings.
Customer: replied 1 year ago.
Hi George
Sorry about the delay it has been a crazy few days including my birthday. Time as well asbfunds have prevented me from taking action. I will get things sorted this week.
Expert:  George-Allsorts replied 1 year ago.
Ok no problem; chat with you when you are ready.
regards
George-Allsorts and other Appliance Specialists are ready to help you