How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dales-Electronic Your Own Question
Dales-Electronic
Dales-Electronic, Home Appliance Technician
Category: Appliance
Satisfied Customers: 1464
Experience:  I am a Home Appliance / Refrigeration Technician of 25yrs+ with my own business and for multi-brand national companies.
26760916
Type Your Appliance Question Here...
Dales-Electronic is online now

I have a beko wm5120s.but it won't start The ready light is on solid and the was

Customer Question

Hi I have a beko wm5120s.but it won't start
The ready light is on solid and the wash light is on solid but the start pause button just flashes. I then press the start pause button again. It will go solid green for 10 seconds then start flashing again like it's in pause. I've cleaned the filter and tried a reset by putting it on 90° pressing and holding the start button whilst turning it on etc.
Submitted: 1 year ago.
Category: Appliance
Expert:  Dales-Electronic replied 1 year ago.
Hello My name is Ian ~ I am not on the site constantly so please be patient whilst waiting for responses to you queries - firstly do this, switch off the appliance and then wait until the door lock has de-energised and then set it on the spin/drain program and start if off - tell me what happens?
Customer: replied 1 year ago.

Hi. Thanks for getting back to me. Its exactly the same. After 10 seconds the start pause light starts to flash but now the spin\end light is on solid instead of the wash light.

Expert:  Dales-Electronic replied 1 year ago.
OK first things first I need you to check that the drain pump is not blocked, its behind the kick strip at the bottom front.
Customer: replied 1 year ago.

Thats the first thing i checked before contacting you as i stated in my question. There was a bit of fluff in there but nothing out of the ordinary

Expert:  Dales-Electronic replied 1 year ago.
OK you have unblocked it but does it actually run when you start the program, the first thing this unit does is pump out the sump so you should hear the pump rotating if not then you need to check that power is getting to the pump whilst you are checking underneath it would be a good idea to check if the motor carbon brushes are not worn out too.
Customer: replied 1 year ago.

Ok im with you. Looking at it there are 3 screws onnthe face of it. Ive undone them then turned the pump which has now released off the metal work. Im assuming this is niw accessible from the underside of the machine. I replaced the brushes last year so im assuming they should be fine but will double check

Expert:  Dales-Electronic replied 1 year ago.
You dont need to take the pump off just check with a mains tester/multimeter that there is power going to the pump when you start the program off.
Customer: replied 1 year ago.

OK. Ive put my ear next to it and turned the machine on. I cant hear anything. Im assuming i should hear a whiring or a clicking matbe but nothing. I dont have a multimeter so cant check if power is getting to the pump but theres certainly no noise

Expert:  Dales-Electronic replied 1 year ago.
OK if I remember correctly this one has a pump and spin program, if you switch it to there do you hear anything when you start it?
Customer: replied 1 year ago.

No cant hear anything

Expert:  Dales-Electronic replied 1 year ago.
OK next question, when you select the program and then start do you hear a click a few seconds after pressing the start?
Customer: replied 1 year ago.

No it makes no noise at all

Expert:  Dales-Electronic replied 1 year ago.
OK well on switch on the door lock is activated using power from the control board behind the facia, you need to establish if power is being received by the door lock (called and interlock) and with the door closed if it is being returned to the control board. Do you have a mains tester or multimeter?

Related Appliance Questions