How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dales-Electronic Your Own Question
Dales-Electronic
Dales-Electronic, Home Appliance Technician
Category: Appliance
Satisfied Customers: 1464
Experience:  I am a Home Appliance / Refrigeration Technician of 25yrs+ with my own business and for multi-brand national companies.
26760916
Type Your Appliance Question Here...
Dales-Electronic is online now

I have a Diplomat adp 8101 dishwasher. When I switch on to

Customer Question

I have a Diplomat adp 8101 dishwasher. When I switch on to "wash" the "in progress" light comes on as usual but nothing happens. Is this the drain pump gone. Thanks
Submitted: 1 year ago.
Category: Appliance
Expert:  Dales-Electronic replied 1 year ago.
Hello My name is Ian ~ I am not on the site constantly so please be patient whilst waiting for responses to you queries - OK can you confirm that on switch on you can hear the drain pump running for a few seconds or a gentle buzzing?
Customer: replied 1 year ago.
No, There is no sound at all! The"In Progress" light stays on.
Expert:  Dales-Electronic replied 1 year ago.
OK please leave this with me, this appliance was built for Diplomat by Brandt who when bust in late 2013. I will have to trawl through my old manuals and see if I can get further information for you.
Customer: replied 1 year ago.
Thanks, Ian
Expert:  Dales-Electronic replied 1 year ago.
.
Customer: replied 1 year ago.
Hi Ian,
You sent me a reply, but there wasn't any text!! Could you resend the answer please?
Thanks,
Robert
Expert:  Dales-Electronic replied 1 year ago.
OK I have now got the manual but there are two versions, one has a mechanical timer the other an electronic one, can you confirm which one yours is please?
Customer: replied 1 year ago.
I don't know!, The timer is on the right of the machine and has 3 settings, pre wash, off and main wash. I think it's a mechanical one.
Regards,
Robert
Expert:  Dales-Electronic replied 1 year ago.
OK this is fairly involved, how are you with handtools, you will need a philips screwdriver and also a Torx 20 screwdriver too.
Customer: replied 1 year ago.
Hi. I am good with diy! Already done various jobs on dishwasher. Have got philips and various torx...20 yes! I have to go out in 5 mins but do answer and I will get back to you later.
Robert
Expert:  Dales-Electronic replied 1 year ago.
OK take off the kickstrip of the kitchen unit, then remove the front panel kickstrip of the dishwasher. Once you have that done ping me.
Customer: replied 1 year ago.
Thanks. Will have to continue tomorrow.
will "ping" you after removal(s)
Robert
Expert:  Dales-Electronic replied 1 year ago.
You should be able to get at this from the front without removing it from the hole. Speak to you tomorrow.
Customer: replied 1 year ago.
Hi Ian,
Have taken off plinths. Can see both pumps. Also folded sheet with electronic info! Will send copy if helpful. It shows testing points and timer testing points.
Robert.
Expert:  Dales-Electronic replied 1 year ago.
No in the middle you will see a mechanical timer witha Torx 20 hole in the middle. Can you confirm this please?
Customer: replied 1 year ago.
Yes, the torx screw is at the bottom of the timer.
Expert:  Dales-Electronic replied 1 year ago.
No you should have a plastic part that sticks out of the centre of the timer with the torx socket in the middle of the plastic.
Dales-Electronic and other Appliance Specialists are ready to help you
Customer: replied 1 year ago.
Sorry! Yes I can see it.
Expert:  Dales-Electronic replied 1 year ago.
OK this appliance had a funny anomaly in that if you tried to use prewash twice ie one after the other it wouldnt work, it had to be used prewash followed by a wash or wash only. If you now turn (with power off) to the 4 o'clock position, (if I remember right there is an arrow pointing to the timer positioning) and then start the appliance it may then run. Come back to me with your results.
Customer: replied 1 year ago.
Hi. Done as you said. Machine started .... I think the drain pump emptied the machine and then stopped. No further sign of life! This is on the prewash setting. Next?!
Expert:  Dales-Electronic replied 1 year ago.
Turn it around to the same place but dont put it on prewash put it on main wash, if it just pumps move it a couple of clicks further.
Customer: replied 1 year ago.
Have done as you said. Pump worked, obviously no water left. Machine then stopped. Went forward a couple of clicks. Machine made unusual rumbling noise, seems to be coming from main pump. Machine stopped again. Small empty cycle then stopped again. Arrow pointing down at 6 o'clock.??
Robert
Expert:  Dales-Electronic replied 1 year ago.
OK another couple of clicks and tell me if it fills?
Customer: replied 1 year ago.
2 clicks on. Machine rumbled again for about 5mins. Then tripped circuit breaker. No water in machine. Have switched off!!
Expert:  Dales-Electronic replied 1 year ago.
OK you seem to have no water going in to the appliance, either the inlet valve is faulty or the timer is not feeding power to the valve. When it has cooled pour some water into the appliance and see if you can get the motor to push it around. Problem is you will struggle to get spares because of the manufactuer going bust.
Customer: replied 1 year ago.
Hi. Tried 2 more clicks on. Circuit breaker went again. Will wait until tomorrow when it is light. I think the element might have blown as there wasn't any water in! Might be able to get element but as you say, valve might be faulty. Have to see as it is 15 years old and probably well past it's sell by date. Will contact you tomorrow. Thanks for advice so far.
Regards,
Robert
Expert:  Dales-Electronic replied 1 year ago.
OK no worries.
Customer: replied 1 year ago.
Hi. Machine seems OK now. It's going through the cycle fine up to now and is emptying and filling just fine. I took the door panel off and have now replaced it. One snag .... The machine is leaking a bit from below the door. I wonder if I missed a rubber seal out or need a new one?! No circuit breaker cut out so far. I wonder if the anti flood mechanism was triggered as there was some residual water in the plastic undertray of the machine. I have dried this up and all seems ok. I shall have to check whether the heater is still working in case I knackered it last night!
Kind regards,
Robert
Expert:  Dales-Electronic replied 1 year ago.
Initially check this, put the spray bars front to back and then switch the appliance on for a couple of minutes - then carefully open the door, you should be able to see the bars rotating. What happens is if they are blocked then the bar stops diagonally across the cabinet and high pressure water hits the splash strips and forces them back allowing a leak. I think with resetting the programmer as we discussed yesterday and letting it cool down things are back to normal, but be aware in the future that you can't do two prewash programs one after the other. Would you now kindly rate the information given to you, by using the stars ratings at the top of the page, this allows me to shut down the job on the system but you can come back to me later if you need further information.
Customer: replied 1 year ago.
Hi, Ian,
I forgot to screw down the bottom p!astic plate which I did in the hope of removing it. I didn't go any further and left them out! Once screwed back down ... No leaks!!
All working fine, BUT no heat. Will replace heater element which is still for sale on a few sites.
Thanks for all your advice and great communications.
Will leave you a good review ..and tip!
Kind regards,
Robert.
Expert:  Dales-Electronic replied 1 year ago.
Many thanks for that, had to laugh I've done the same a few time too. Take care - Ian
Customer: replied 1 year ago.
Hi Ian
It's me again, Robert Archer! Sorry to be a pain, but have replaced element. No heat!! I think it is one of the thermostats. I know the limiter has a rest button on it. Do I have to take the machine out to replace it and where is it, on bottom of this model?
Thanks
Robert

Related Appliance Questions