How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Michael Your Own Question
Michael
Michael, Customer Service
Category: Appliance
Satisfied Customers: 9568
Experience:  I have been an appliance repair tech for over 30 years and will help you solve your problems.
11519491
Type Your Appliance Question Here...
Michael is online now

My Beko WMB 71642 W has developed an odd problem. It works

Resolved Question:

Hi. My Beko WMB 71642 W has developed an odd problem. It works perfectly on all programs but the Self Clean one. All seems well when you set it off. It's says the program will run for 2:26 but it will only run for approx 10 mins and say End. I've not got any fault codes stored so I'm at a Los what the problem may be. Have you an idea? I'd be blvery grateful for dome advice. Many thanks Mike
Submitted: 1 year ago.
Category: Appliance
Expert:  Michael replied 1 year ago.
Hi Mike, I am Tech Michael a specialist expert in this field and I will be assisting you today. I am a Master Technician that's dedicated to giving you the best Answer possible.If you are new to the site, this is briefly how it works:1. We may need some back and forth to exchange information (if needed) and there is no extra cost for replying.2. I will give you the best possible Answer for your problem without the ability of actually being present with you.The better you describe the problem, the quicker I can help ;-)3. Remember to leave a Positive Rating ,it doesn't cost anything additional to rate kindly;-)I am only credited for my time and expertise if you rate kindly.How old is your Beko Washer ? Thank youTech Michael
Customer: replied 1 year ago.
Thanks for the quick response. Well the machine is nearly 4 yrs old now. It was bought in the middle of 2012.
Regards
Mike
Expert:  Michael replied 1 year ago.
Hi Mike, thanks for that info.This unfortunately is a the main control board at fault.That board needs to be replaced;-( Its easy to do, and there is no soldering needed.If you do replace that main control board, make sure you tell the supplier you want a board with a pre programmed IC!Otherwise you may get one that needs programming for an appliance repairman still lol, not a good thing at all.The best place to get that board is: http://www.espares.co.uk/I would call them to inquire about this circuit board: 0844 9777 888.I will stick with you until this is complete.Please rate my service thus far.EXCELLENT (5 Stars) would be greatly appreciated.There is NO cost to rate Kindly;-)Also it is the only way I am credited for my time and expertise with you.Once you rate, I will be notified and will add your question to my priority list so you can reach me anytime until this problem is solved.Then you can reach me by simply replying to this message anytime.Thank you and have a great day! Tech Michael
Michael and other Appliance Specialists are ready to help you
Customer: replied 1 year ago.
Thanks very much. I was hoping it may be something like this. I'll rate you right now and I'll keep you informed how I get on.
Milan thanks
Mike
Expert:  Michael replied 1 year ago.
Sounds Have a great weekend.Tech Michael
Customer: replied 1 year ago.
I received the new board this afternoon. I've just fitted it and tried the machine out. It still doesn't work on the self clean cycle but now I'm getting a E18 code. The drain pump has started to make a grumbling sound like it's not able to pump properly. It also seems rather slow. It didn't do this the other day. I've checked the filter etc and it's completely free from any blockages.
Mike
Expert:  Michael replied 1 year ago.
Hi Mike, do the programs seem to set properly?Also what does seem to work?ThanksTech Michael
Expert:  Michael replied 1 year ago.
its possible you have either a bad ground wire somewhere or possibly a bad drain pump as well.Please check for that.ThanksTech Michael
Customer: replied 1 year ago.
I've just got home from work now so I'll run through the programs after checking the integrity of the the earth's.
Regards
Mike
Expert:  Michael replied 1 year ago.
Hi Mike Im here when you need;-) Please rate kindly so we dont get separated.ThanksTech Michael
Customer: replied 1 year ago.
I've checked through all connections on the main bad and they were ok. The seperate power supply board had a few questionable solder joints on which I dealt with. The pumps connections were all good as well. All the grounding points check out and the E18 fault code has now gone. All the programs seem to work still except the self clean. Which still ends after approx 10 mins. On thing is quite noticeable is that the water isn't being pumped away very quickly. The pump sounds like it's running faster than usual, quite like it hasn't alot of water in it to pump. It's certainly quite noticeable in the noise it's now making.
Many thanks
Mike
Expert:  Michael replied 1 year ago.
Hi, Mike,sounds like your doing ok, but you may need a new drain pump.Hopefully that will solve all the issues finally;-) But if not let me knwo and we can go from there.Tech Mike ;-)
Customer: replied 1 year ago.
Hi Mike.
Thanks for getting back to me so quickly. I've ordered a new pump so hopefully it'll be here tomorrow all going well. I'll let you know the outcome!
Many thanks
Mike
Expert:  Michael replied 1 year ago.
Hey, no problem, let me know how it all goes, but please rate my service so I can place you in my priority list. That way I will see your question straight away and be able to reply to you when you have the part;-) Thank you and have a wonderful day!Tech Mike
Customer: replied 1 year ago.
Hi Mike.
I received the drain pump today. I've fitted it and have ran through all the programs. It's now working perfectly. Pumps nice and quiet and is a lot quicker to drain as well!
Not the easiest thing to fit mind you!
Many thanks
Mike
Expert:  Michael replied 1 year ago.
Hi lol, Mike, Im glad its done and working as it should ;-)Sorry I said it was really easy to do lol, if I didn't you might not have wanted to to save the money for a technician lol. Anyway, have a great day and let me knwo if you have any other trouble.Tech Michael
Customer: replied 1 year ago.
Hi Mike.
Not a problem. It wasn't too bad to work on really. Tbh I quite enjoyed the challenge. Thanks for all your help.
Mike