How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Michael Your Own Question
Michael
Michael, Customer Service
Category: Appliance
Satisfied Customers: 9568
Experience:  I have been an appliance repair tech for over 30 years and will help you solve your problems.
11519491
Type Your Appliance Question Here...
Michael is online now

My Bissell 23K5-E Lift- off mop will not steam and there seems

Resolved Question:

My Bissell 23K5-E Lift- off mop will not steam and there seems to be no water getting through to the mop head despite fitting a new water filter to it
Submitted: 1 year ago.
Category: Appliance
Expert:  Michael replied 1 year ago.
Hi, I am Tech Michael an expert in this field and I will be assisting you today. I am a Master Technician that's dedicated to giving you the best Answer possible.If you are new to the site, this is briefly how it works:1. We may need some back and forth to exchange information (if needed) and there is no extra cost for replying.2. I will give you the best possible Answer for your problem without the ability of actually being present with you.The better you describe the problem, the quicker I can help ;-)3. Remember to leave a Positive Rating ,it doesn't cost anything additional to rate kindly;-)I am only credited for my time and expertise if you rate kindly.How old is your Bissell?Is there any sign of life form it?And did it fail during operation or was it like that when you plugged it in? Thank youTech Michael
Customer: replied 1 year ago.
less than 2yr old , the blue ready light comes on when plugged in after a few seconds but no steam and mop head not even getting damp.Started doing this after purchasing a new water filter.
Expert:  Michael replied 1 year ago.
Hi thanks, ***** ***** use would you say its seen?Thank you for your patience.Tech Michael
Customer: replied 1 year ago.
only used it about 15 times in all
Expert:  Michael replied 1 year ago.
Thanks, ***** ***** tell if the unit seems to get warm at least or it stays completely cold?That will tell me the story and what is wrong;-) Thank youTech Michael
Customer: replied 1 year ago.
stays cold but there is power to the unit as the blue ready light comes on
Expert:  Michael replied 1 year ago.
i thank you for that information.You have a bad heater or thermal fuse inside the Bissell unit. Do you have a meter for some tests?Also this one will need to be opened to fix this problem. It is worth the cost for repair even if you have a vacuum cleaner repair shop do this for you as well;-)Either way working further with me to solve the problem or having a shop do this one, please let me know?The part if its just the thermal fuse is less than $1.00 US for that part, if its the heating element it costs about $20.00 US for the part.So even labor wont be much more than that;-)In any case, I will stick with you until this is complete.Please rate my service thus far.Also it is the only way I am credited for my time and expertise with you.Once you rate, I will be notified and will add your question to my priority list so you can reach me anytime until this problem is solved.Then you can reach me by simply replying to this message anytime.Thank you and have a great day! Tech Michael
Michael and other Appliance Specialists are ready to help you
Customer: replied 1 year ago.
ok thanks , will take it to a repair shop
Expert:  Michael replied 1 year ago.
Hi , I wish this were a do it yourself project I do. But I'm sure it wont be too expensive to have repaired ;-)Thank you and have a wonderful day!Tech Michael