How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Michael Your Own Question
Michael
Michael, Customer Service
Category: Appliance
Satisfied Customers: 9568
Experience:  I have been an appliance repair tech for over 30 years and will help you solve your problems.
11519491
Type Your Appliance Question Here...
Michael is online now

I have a CM900 Room thermostat and Relay box. Heating is

Resolved Question:

Hi I have a CM900 Room thermostat and Relay box. Heating is not on. I have done rebinding several times. Green light is on relay box now and flame showing on room thermostat. but boiler not kicking in. Water is fine but no heating kicks in. Tried everything, new batteries, several attempts at test and rebinding. Help please.
Submitted: 1 year ago.
Category: Appliance
Expert:  Michael replied 1 year ago.
Hi, I am Tech Michael an expert in this field and I will be assisting you today. I am a Master Technician that's dedicated to giving you the best Answer possible.If you are new to the site, this is briefly how it works:1. We may need some back and forth to exchange information (if needed) and there is no extra cost for replying.2. I will give you the best possible Answer for your problem without the ability of actually being present with you.The better you describe the problem, the quicker I can help ;-)3. Remember to leave a Positive Rating ,it doesn't cost anything additional to rate kindly;-)I am only credited for my time and expertise if you rate kindly.How old is your CM900 Room thermostat ? Thank youTech Michael
Customer: replied 1 year ago.
3 years new with new Worcester boiler
Customer: replied 1 year ago.
The exact model is CM 927
Expert:  Michael replied 1 year ago.
Hi please try one thing for me so I can be sure where we are with this system.Make sure it is wired correctly.Turn off power to the boiler, next remove the batteries from the T stat and place then back in but in reverse polarity and leave it that way for 1 full minute. Then remove the batteries and check the contacts in the battery box for corrosion, let me know if you find any? They contacts shoudl look clean bright and shiny. If not you need to clean them with some solvent on a lint free cloth. I will go further on that if we need to;-)Then replace the batteries with Only BRAND NEW Duracell brand batteries for this one.Turn power back on at the boiler and let me know if it will work. In any case, I will stick with you until this is complete.Please rate my service thus far.Also it is the only way I am credited for my time and expertise with you.Once you rate, I will be notified and will add your question to my priority list so you can reach me anytime until this problem is solved.Then you can reach me by simply replying to this message anytime.Thank you and have a great day!Tech Michael
Customer: replied 1 year ago.
Thank you Michael that was no help at all! Seems it is a problem with the diverting valve - so now have paid £20 and call out for electrician, plus probably around £200 for new part - expensive day!
Expert:  Michael replied 1 year ago.
Hi Im sorry to here that. In some cases the problem will be the diverter. But its rare and usually this problem is on the electronic end of the system, I know because I service these daily over the past 30 years myself lol;-)Wish I had it correct, sorry that happens as well;-(In any case Im glad its working.I hope the part isn't that expensive.Sometimes even the diverter will fail sorry it was that serious.Have a great day anyway.Tech Michael
Michael and other Appliance Specialists are ready to help you