How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Rob Your Own Question
Rob
Rob, Home Appliance Technician
Category: Appliance
Satisfied Customers: 420
Experience:  20 yrs. experience with a major worldwide manufacturer.
14831508
Type Your Appliance Question Here...
Rob is online now

I have just installed a new wash pump on a commercial

Customer Question

Hi
I have just installed a new wash pump on a commercial zanussi dishwasher model ls9adg1. The pump works put the machine won't go into cycle and the display is displaying FILL even though it is full of water.
Submitted: 1 year ago.
Category: Appliance
Expert:  JamesI replied 1 year ago.

The fact water is entering the washer, this proves the valve and actuator are working, this would sounds like a sensor fault.

I would check the water level sensor using a multi meter, it may be a faulty sensor or lose cable. Let me know how you get on.

Customer: replied 1 year ago.
Great thanks, ***** ***** where this might be?
Cheers
Expert:  JamesI replied 1 year ago.

I dont have the schematic for you model, however they are normally located at the bottom of the unit and the inlet hose hose is attached to some form of manifold.

If its not easily visible from where you installed the pump, have a look underneath.

I would also look to check all the cables from the PCB are connected properly, as it may be a lose connection which is preventing the dishwasher from moving through the cycle.

James