How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Rob Your Own Question
Rob
Rob, Home Appliance Technician
Category: Appliance
Satisfied Customers: 420
Experience:  20 yrs. experience with a major worldwide manufacturer.
14831508
Type Your Appliance Question Here...
Rob is online now

I have a Worcester Heatslave 20/25 Last night we noticed

Customer Question

I have a Worcester Heatslave 20/25
Last night we noticed heating and hot water switched off.
The lcd screen was still working but even when clicked through Off/Once/ Twice to On it didn’t turn on and red light did not come on.
Seems like it has lost power to the system. I assume display has a back up battery but today the lcd screen has stopped working.
Fuse in wall point is ok and is definitely receiving power to there (we have Honeywell Evohome Wireless unit wired in and light on this unit comes on)
Could it be a relay issue or pcb failure?
Any advice appreciated. Have baby in the house and really need hot water and heating back.
Thanks joe
Submitted: 1 month ago.
Category: Appliance
Expert:  Andrew Smith replied 1 month ago.
Can you confirm if this is the oil model?
Customer: replied 1 month ago.
Customer: replied 1 month ago.
it is oil fuelled
Expert:  Andrew Smith replied 1 month ago.

ok, your model has a red light?

Can you confirm it is not illuminated?

Customer: replied 1 month ago.
There were no red lights on.
I had been looking at the control box PCB. In doing this I removed and reconnected the connections to PCB from the ‘Power On’ and ‘Lock Out’ lights.
In doing this it started working just now.
I then powered it back off while I replaced covers. It then did now work.
I then repeated the above and it worked again and still is.
Customer: replied 1 month ago.
Photo here
Expert:  Andrew Smith replied 1 month ago.

Was the red light on on the control box down below?

If you press it, it resets the unit if it has tripped out

Expert:  Andrew Smith replied 1 month ago.

It looks like it is working now?

Customer: replied 1 month ago.
There is a red trip switch below control box. This has not tripped at any point.
Is it likely there’s an loose connection or intermittent fault in the control board somewhere.
Yes working now.
Expert:  Andrew Smith replied 1 month ago.

Strange if it has not been taken apart and something is loose?

All i can say is monitor it and see how you go over the next day or so.

Customer: replied 1 month ago.
I did move the front plate down to look so unplugged some bits and moved some wires.
Expert:  Andrew Smith replied 1 month ago.

ok, something could have been loose, but now its back together?

How about you monitor and come back tomorrow and we see how its done?

Customer: replied 1 month ago.
Sounds good. Thank you.
Just in time for baby bath time!
Cheers
Expert:  Andrew Smith replied 1 month ago.
Ok, leave the question open and do not try until tomorrow and I should get a notification when you do