How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Billy Your Own Question
Billy
Billy, Trainer/ Master Technician
Category: Audi
Satisfied Customers: 3498
Experience:  Trainer 8+ years, master tech. 10+ years, SAE member
30385560
Type Your Audi Question Here...
Billy is online now

I have an audi A6 saloon FV54TYG 2.0 TD purchased in 2004.

Customer Question

I have an audi A6 saloon FV54TYG 2.0 TD purchased in 2004. About 2008, after leaving it in the garage for 7 days it would not start. After turning the engine over to the point of flattening the battery, it eventually started. It was like 'fuel starvation'!! I changed the fuel pump in the boot. 6 months latter the same thing happened, and so it went on. Fuel seals were changed twice! eventually, last month , teh Tandem Fuel pump was changed as we had been advised that audi had had problems with them. I thought that I had at last fixed the problem! Unfortunately no! We difficulty start it yesterday. Have you any ideas on what it could be. It is costing a fortune to fix!!!
Regards XXXXX
Submitted: 4 years ago.
Category: Audi
Expert:  Shantal-Mod replied 4 years ago.

Hello David,

I've been working hard to find a Professional to assist you with your question, but sometimes finding the right Professional can take a little longer than expected.

I wonder whether you're ok with continuing to wait for an answer. If you are, please let me know and I will continue my search. If not, feel free to let me know and I will cancel this question for you.

Thank you!

Shantal

Customer: replied 4 years ago.


Please take as long as you like. The problem has been with me for 5 years now!!! I just need some good answer. It seems to me more like a fuel problem rather than electronic. It is so intermittent. The vehicle does not necessarily have to be parked on the slope of the drive for this to happen????


 


Regards David Pritchard

Expert:  Shantal-Mod replied 4 years ago.

Hello David,

We will continue to look for a Professional to assist you.


Thank you for your patience,

Shantal

Expert:  Billy replied 4 years ago.
Hello David! I'm Billy and i will assist you with this. Feel free to ask if further info is needed.

My apologies for the delay, thank you for your patience.

- what do you mean by " The vehicle does not necessarily have to be parked on the slope of the drive for this to happen????" is the engine hard to start everyday, wherever you park, or when you leave it for a long time?


- and after replacing the tandem pump, did it fix the problem?
- was the fuel filter checked (replaced or checked for leaks)?
- can you provide the engine code (should be a 3-letter code, like BNF, BNA, BVG)?
- was the EGR valve checked/cleaned, as this can cause hard cold starts, just like fuel lack..
- do you have any warning lights on dash, or any other problems or symptoms after the engine starts (reduced performance, rattle, hesitation etc.,..)?

Since replacing the pump cured the problem for six months, then the pump was faulty at the time, and now something else is...

Regards, Billy
Customer: replied 4 years ago.


Hello Billy. Thank you for your reply. My local garage thought that parking the Audi on the slope on my drive could cause the fuel to drain back. this was dismissed as it did not matter where the car was parked, if it decided not to start. I found that if I kept turning the engine over it would eventually start to fire up. My local garage ( he is VW and Audi trained) made enquiries with the Grimsby Audi dealer and found that Audi had problems with the old Tandem pump so we decided to change the pump on my car! It looked as if we had cured it. But last week my wife had difficulty starting it again! The fuel filters have been changed, but I am not sure about the EGR valve?


The engine code is BLB and gear box code is GYX. No warning lights come on.


 


Regards David

Expert:  Billy replied 4 years ago.
Hello David!

Having replaced the pumps and filter, i would next check and clean the EGR valve, just to make sure it is not causing the problem. Then, we confirm this a fuel issue. Accordingly, the next check would be getting a transparent hose on the diesel suction line getting to the unit injectors, to make sure no air is being drawn (caused by a small crack somewhere in the fuel line). If these checks are performed, then next thing to check would be the unit injectors (pump injectors: on your engine, the pump and injector are integrated as one unit driven by a camshaft beneath the valve cover).

Get back to me with the results, so we proceed accordingly.

Regards, Billy
Customer: replied 4 years ago.


Hello Billy. Thank you for your reply.. I will pass on this information to my mechanic. You have been very helpful.


 


Regards David.

Expert:  Billy replied 4 years ago.
Hello David,

You're most welcome! Get back to me with your results, or if further info is needed.

Regards,
Billy