How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask David-VAG Your Own Question
David-VAG
David-VAG, ASE Certified Technician
Category: Audi
Satisfied Customers: 844
Experience:  I've been working within the Audi group for over 10 years diagnosing and repairing them
27984060
Type Your Audi Question Here...
David-VAG is online now

Hi, I have a December 2001 Audi A4 B6 tdi 130bhp, car runs

Customer Question

Hi, I have a December 2001 Audi A4 B6 tdi 130bhp, car runs stunnigly, even with
Just under 200.000 on the clock! . not that I do this but!, on going uphill sometimes
Goes into limp mode at about 2&half rpm. Switch engine off & back on again & hay
all ok again. yethe other thing is...... On the flat!!! It will rev and climb towards the red
And does'nt go into limp mode. ...... Weird, any help or advice id be real Gratefull thanks
GdG :-D
Submitted: 3 years ago.
Category: Audi
Expert:  David-VAG replied 3 years ago.

Hello and welcome to just answer

It sounds very much like you have a problem with the turbo becoming sticky. These run a variable vane turbo and they can get full of carbon build up which causes the little vanes to stick. They tend to stick in the full turbo position as that part is rarely used except when you are using the engine to go up hill or pull away really quickly.

When you turn the engine off the actuator on the turbo then pulls the vanes free and you are up and running again as before and works fine unitl you use the higher boost on the turbo.

Innotec-world.com offer a cleaning set which has been designed to be used on these turbos to help remove the carbon build up.

I hope this helps and if I can help further please feel free to ask

Dave

Customer: replied 3 years ago.
I am sorry! , I forgot to mention in my first email.... New Turbo has been fitted also...?
Expert:  David-VAG replied 3 years ago.

Hi thank you for that.

Have you ever had the fault memory checked for the engine ecu and if so so you remember what codes if any that were stored in it please?

Dave