How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Matt Your Own Question
Matt
Matt, Mechanical Engineer
Category: Audi
Satisfied Customers: 21989
Experience:  BEng hons Mech engineering, in auto industry 22 years
12772297
Type Your Audi Question Here...
Matt is online now

Replaced the coolant sensor and the temperature sensor in my

Resolved Question:

Replaced the coolant sensor and the temperature sensor in my audi a4 51 reg,but when I turn the ignition off the fan comes on and keeps running till the battery goes flat.
Submitted: 3 years ago.
Category: Audi
Expert:  Matt replied 3 years ago.
Hello

this sounds like the fan control module ( on the back of the fan) is faulty

it should look like this

graphic

its about £70 to 80 but its a easy thing to fit
Customer: replied 3 years ago.
Just checked the ecu box for the relay and found it submerged in water I took it out and cleaned it put it back on now the fan comes on with the ignition as does the red oil light but now the car won't start just turns over,has this been caused by me disconnecting the ecu,the battery was disconnected at the time?
Expert:  Matt replied 3 years ago.
Hello Mark

I'd check that you've gotten 12V at the fuses for the ECU as the next step and its quite possible that the ECU has been damaged due to the water

if there' spower to the ECU but no spark / engine running then I'd suggest sending off to 1 of these firms for inspection / repair

http://www.the-ecu-doctor.co.uk/

http://www.bba-reman.com/uk/
Matt and other Audi Specialists are ready to help you