How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Matt Your Own Question
Matt
Matt, Mechanical Engineer
Category: Audi
Satisfied Customers: 21632
Experience:  BEng hons Mech engineering, in auto industry 22 years
12772297
Type Your Audi Question Here...
Matt is online now

I have just changed the power steering pump on my Audi A4 3.d

Customer Question

I have just changed the power steering pump on my Audi A4 3.d quattro taken off the front bumper and headlights and it will now not start once all back together, can you please help?
Submitted: 2 years ago.
Category: Audi
Expert:  Shantal-Mod replied 2 years ago.
Hello,
I'm Shantal and I'm a moderator for this topic.
I've been working hard to find a Professional to assist you with your question, but sometimes finding the right Professional can take a little longer than expected.
I was checking to see if you had already found your answer or if you still need assistance from one of the Professionals.
Please let me know if you wish to continue waiting or if you would like for us to close your question?
Thank you,
Shantal
Expert:  Matt replied 2 years ago.
Hello

assuming the engine cranks OK then I'd check the connections to the air flow meter thats built into the intake trunking just after the air / filter box

if thats OK then its worth checking that the electric pump that feeds the main fuel pump is working correctly, it should run for a few seconds then switch off when you first turn the ignition on. If the connections to this are corroded or damaged then the pump could stop at any time. Check that its relay switches in and out and the relay contacts are clean and bright – replace the relay if in any doubt and do the same for the fuse, ideally measure the voltage at the pump and check its getting 12V
Also if its not injecting at all then check the connections to the crankshaft sensor, unplug it and check for corroded contacts and broken wiring, and consider fitting a new sensor - do the same for the cam position sensor
If the EGR valve is stuck open then this too can effect starting so try disconnecting it to see if this helps or changes anything