How JustAnswer Works:

  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.

Ask Matt Your Own Question

Matt
Matt, Mechanical Engineer
Category: Audi
Satisfied Customers: 20592
Experience:  BEng hons Mech engineering, in auto industry 22 years
12772297
Type Your Audi Question Here...
Matt is online now

My car is a 2008 Audi A4 Avant S Line 2.0 TDI Whilst travelling

Customer Question

My car is a 2008 Audi A4 Avant S Line 2.0 TDI
Whilst travelling along the motorway the oil glow light started flashing and I suffered a loss of power from the engine. I slowed down but after approx 3 miles I lost all power and pulled into the side as the engine had cut out
The car engine turned over on the key but would not start again!
Help!!!
Please!!!
Best regards
Ossie Hall
Submitted: 1 year ago.
Category: Audi
Expert:  Matt replied 1 year ago.

Hello

On any car if you get a check engine light or other fault light this typically means one or more of thesensors has failed or has a faulty connection.

The fault can be something quite simple and nothing that’s going to stop the car to something quite major that will reduce engine power and possibly stop the engine

The ECU senses this and may put the car into 'limp home' mode which typically limits the revs and the amount of power available.Usually the car is safe to drive for a short distance as the mode is intended is intended to get you home without incurring any engine damage

The quickest route to repair is to have the car plugged into a diagnostic machine which will read off the fault code stored in the ECU (providing the light is still on at this point) and indicate which sensor has failed or whether the fault is more serious.

You can do a very rough and ready check yourself by unplugging sensors one at a time and seeing if any of them change the driving condition which would indicate the most recently unplugged sensor is the faulty one.This method is not foolproof though and reading a fault code off is the better method.

however there's some basics you can check

This could be a lack of fuel pressure from the electrical pump at the tank.

If the connections to this are corroded or damaged then the pump could stop at any time or could not be running at full speed. Check that its relay switches in and out and the relay contacts are clean and bright – replace the relay if in any doubt and do the same for the fuse,
Ideally measure the pressure at the inlet to the main engine fuel pump and if this is low check the pump as described and also consider changing the fuel filter as if this partially blocked this too will reduce pressure.

If both of these are OK then also check the connections to the EGR valve, if either the vacuum pipe of electrical connection are damaged / corroded then the EGR can be on all time which certainly will hurt performance. Its also possible that its a fault with the EGR valve so its worth removing the valve and cleaning it out with brake cleaner, if it looks particularly clogged then replace it.

If this is OK then check the small vacuum lines to the turbo and its connected control solenoid on the bulkhead, any cracks or leaks can give turbo issues and its best to have the boost pressure measured actually measured with a boost gauge to check that the turbo is healthy and that the sensor is reading correctly

If its a variable vane turbo (they’ll be an actuator on the turbo body - but not a wastegate) then check its vacuum pipework as above and check the connections to the diaphragm / solenoid valve

Also worth checking that the glow-plug relay is switching off as they can stick on and leave the glow plugs also on - on some cars this can force it into limp home

Also worth considering adding a bottle of injector cleaner into the tank as a clogged injector nozzle will reduce powerand give poor combustion - the next stage on from this is to remove all the injectors and have them ultrasonically cleaned and flow checked

Also check all the high pressure hoses post turbo/s for any split hoses or cracked metal pipes, also check the ends of the intercooler as its not unheard of to pop the end caps off under high boost.

Expert:  Matt replied 1 year ago.

hi

do you still need help with this?

Customer: replied 1 year ago.

Sadly yes!

The Audi has been in garage for 2 weeks!

They have found a lot of oil in tank-now all cleaned out

Had injectors cleaned professionally and put back on

The particulator filter cleaned thoroughly and put back on

fuel filter really oiled up -now cleaned and back on

Replaced the something pump?

cleared everything down on computer

They started it up and took it for run

Started fine and went OK for a while but then the glow plug came on and the car went into limp mode

Oh dear-- please give me something for garage to try!!!

Expert:  Matt replied 1 year ago.
Hello

I'd suggest removing the air intake and check inside for more oil as it can settle there and be pulled into the engine later on
Customer: replied 1 year ago.

Yes indeed, they have checked that out.

The problem is they cannot locate how or where the oil was coming from in the first place to clog everything up

Everything through the system is now apparently clean but the car still closed itself down after starting OK and running OK for a while(initially it would not even start)

The proprietor believes it could be the oil is getting in via the seating of the injectors which, on this model Audi, do not have copper/brass washers seating them onto the cylinder head

What do you think?

Grateful for your comments

Thank you

Customer: replied 1 year ago.

Yes indeed, they have checked that out.


The problem is they cannot locate how or where the oil was coming from in the first place to clog everything up


Everything through the system is now apparently clean but the car still closed itself down after starting OK and running OK for a while(initially it would not even start)


The proprietor believes it could be the oil is getting in via the seating of the injectors which, on this model Audi, do not have copper/brass washers seating them onto the cylinder head


What do you think?



Grateful for your comments



Thank you

Best regards

Ossie Hall



Expert:  Matt replied 1 year ago.
Hello Oswald

the injectors do rely on a face to face seal which can weep oil into the cylinder over time but its usually a really small amount - unless the cylinder head is cracked
Which isn't something I've heard of on these

if you have a glow plug light on this means there should be a fault code which can be read off so I'd say this should be the next step as it will point to the fault

What Customers are Saying:

 
 
 
  • 9 dollars, 2 hours of my time, and I drove away. Your diagnosis was right on the mark. Thank you so much. Phil
< Previous | Next >
  • 9 dollars, 2 hours of my time, and I drove away. Your diagnosis was right on the mark. Thank you so much. Phil
  • Lurch. Thank you very much. I had real doubts about this website but your promptness of response, quick followup and to the point answer with picture was incredible. Charles
  • As a single woman, I really appreciate an excellent and affordable opinion.
    Thank you Geordie, I will not hesitate to contact justanswer in the future!
    Sue
  • Another great insight to what may be the problem. I will have my mechanic take a look at it tomorrow. Thanks again, Frank...you do indeed know your stuff. Jim
  • I would (and have) recommend your site to others I was quite satisfied with the quality of the information received, the professional with whom I interacted, and the quick response time. Thanks, and be sure that I'll be back whenever I need a question answered in a hurry. Stephanie P
  • Wonderful service, prompt, efficient, and accurate. Couldn't have asked for more. I cannot thank you enough for your help. Mary C.
  • This expert is wonderful. They truly know what they are talking about, and they actually care about you. They really helped put my nerves at ease. Thank you so much!!!! Alex
 
 
 

Meet The Experts:

 
 
 
  • Matt

    Matt

    Mechanical Engineer

    Satisfied Customers:

    182
    BEng hons Mech engineering, in auto industry 22 years
< Last | Next >
  • http://ww2.justanswer.com/uploads/35/350matt/2012-6-7_182356_matsavatr.64x64.jpg Matt's Avatar

    Matt

    Mechanical Engineer

    Satisfied Customers:

    182
    BEng hons Mech engineering, in auto industry 22 years
  • http://ww2.justanswer.com/uploads/audidoc/2008-12-23_175252_headshot.jpg AudiDoc's Avatar

    AudiDoc

    ASE Certified Technician

    Satisfied Customers:

    1583
    Independent European garage owner. Over 20 years experience
  • http://ww2.justanswer.com/uploads/MI/mikeamechanic/2013-4-2_175558_photo.64x64.JPG mike_a_mechanic's Avatar

    mike_a_mechanic

    Mechanic

    Satisfied Customers:

    70
    17 years experience as a auto mechanic, foreign and domestic.5 years running my own repair business.
  • http://ww2.justanswer.com/uploads/FO/fordtwo/2014-12-19_163422_arrepair.64x64.jpg Robert's Avatar

    Robert

    UK Qualified Car Technician

    Satisfied Customers:

    36
    Fully qualified 19+yrs exp/self employed technician in the UK
  • http://ww2.justanswer.com/uploads/IN/indytech/2013-8-8_102717_SantoDomingo146598x6402.64x64.jpg Greg's Avatar

    Greg

    Technician

    Satisfied Customers:

    1080
    Automotive diagnostic tech
  • http://ww2.justanswer.com/uploads/TE/techmachine/0601821347169_717372168_8940977_39623330_o.64x64.jpg Ross's Avatar

    Ross

    Diagnostic and repair technician

    Satisfied Customers:

    453
    Licensed diagnostic and repair technician