How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Matt Your Own Question
Matt
Matt, Mechanical Engineer
Category: Audi
Satisfied Customers: 227
Experience:  BEng hons Mech engineering, in auto industry 22 years
12772297
Type Your Audi Question Here...
Matt is online now

2001 (B6) Audi A4 Avant-Connecting Canbus Steering Controls

Customer Question

I recently bought a 2001 (B6) Audi A4 2.0 Avant with an aftermarket stereo fitted. The car has steering wheel controls fitted and a rear amp, but they were not connected. Prior to aftermarket stereo, it was a non-Bose system (rear speakers amp'd by Harman amp in boot). So, I've sourced the appropriate Connects2 wiring harness and have plugged it in, restoring the rear amp to operation - success. But the Connects2 steering wheel controls Canbus adapter is proving more trouble. There are the power lines (permanent, switched and ground) which the Connects2 harness connects to relevant leads available behind the stereo, but the two brown wires into the Connects2 Canbus adapter to supply the steering controls data feed do not correspond to any of the wires available behind the stereo. The supplied Connects2 harness non-ISO audi specific connector presents the two brown wires from the C2 Canbus adapter at PIN 11 (Remote) on the non-ISO Audi connector that is on the car side (e.g. for pre-out rear speaker feeds and amplifier switch aswell). The Audi side 20 pin non-ISO adapter does not have any corresponding wires that connect to PIN 11.  But does have two wires connect to PIN 7 "CAN-H" and PIN 12 "CAN-L".

So - PIN 7 and PIN 12 seem to be the wires that present canbus connectivity to the head unit.  But how does this correspond to the Connects2 box side - where two brown wires are joined together and then connected to PIN11.

Have I got the wrong Connects2 box - It's CTSAD001.2 - states it's for steering controls for 93-06 Audi?  Or am I missing something else?

Submitted: 2 years ago.
Category: Audi
Expert:  Shantal-Mod replied 2 years ago.
Hello,
I'm Shantal and I'm a moderator for this topic.
I've been working hard to find a Professional to assist you with your question, but sometimes finding the right Professional can take a little longer than expected.
I was checking to see if you had already found your answer or if you still need assistance from one of the Professionals.
Please let me know if you wish to continue waiting or if you would like for us to close your question?
Thank you,
Shantal
Customer: replied 2 years ago.

Hi Shantal,

I've now found an answer elsewhere. Could you close the question and refund the £13 please?

Thanks

Mark