How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Steve Your Own Question
Steve
Steve, BMW Expert
Category: BMW
Satisfied Customers: 24268
Experience:  BMW Expert
26942375
Type Your BMW Question Here...
Steve is online now

hi, i have a bmw 318! se 2009. few weeks ago the engine light

Customer Question

hi, i have a bmw 318! se 2009. few weeks ago the engine light came on and my garage mate changed the cam shaft sensor it also had a problem with the ecu which has now been fixed. but the engine is still not running correctly. still lacking in power and running rough when idiling.
Submitted: 4 years ago.
Category: BMW
Expert:  Steve replied 4 years ago.
Hi,

If this car is still running poorly, what was fixed?
Customer: replied 4 years ago.


yes still running poorly. had the cam shaft sensor replaced and a chip on the ecu unit.

Expert:  Steve replied 4 years ago.

who replaced what chip on the ecu?

 

Customer: replied 4 years ago.


it was a local garage who specialise in tuning performance cars etc. not too sure what chip he replaced.

Expert:  Steve replied 4 years ago.

what warning lighs are on and what fault codes are stored?

 

Customer: replied 4 years ago.
Sorry for the delay. It has two error codes.2a87 and 30c1
Expert:  Steve replied 4 years ago.
One moment please
Expert:  Steve replied 4 years ago.

 

Please do not forget to click a positive rating as this is the only way I receive credit for my answer, thank you.

 

Neither of these codes is for a cam sensor

 

the first one points to a vanos / solenoid issue, or a legitimate camshaft / bearing issue

 

the second one related to an oil pressure control fault, which could be related to the ecu, oil pump, pressure sensor, or legitimate oil pressure problem

 

 

it is possible that both codes are being caused by an oil restriction of some kind as well

you would be strongly advised to use only a BMW Specialist if you are not

 

Please let me know if you have further questions. Please do not forget to click a positive rating as this is the only way I receive credit for my answer, thank you. Best wishes with your repairs.