How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Steve Your Own Question
Steve
Steve, BMW Expert
Category: BMW
Satisfied Customers: 24178
Experience:  BMW Expert
26942375
Type Your BMW Question Here...
Steve is online now

i have a bmw e39 535i on a s plate..sometimes my car struggles

Resolved Question:

i have a bmw e39 535i on a s plate..sometimes my car struggles to start..when i turn ignition on it turns over but it sounds like its not getting any fuel or too much...ive had o2 sensor replaced after diagnostics check..ok for week or so but its started again..no errors found after another diagnostcs check...please help as it cant be doing engine any good,,,regards steve
Submitted: 3 years ago.
Category: BMW
Expert:  Steve replied 3 years ago.
What is fuel pressure when it fails to start?
Customer: replied 3 years ago.

i have no idea..when it eventually starts it runs absolutely fine tho

Expert:  Steve replied 3 years ago.

I will provide an honest answer. I trust this will be appreciated. Please remember that a low rating PUNISHES me for being honest and that I receive nothing for my time until a positive rating is clicked.

 

when the car fails to start, usually this is because there is no fuel being delivered.

 

the most common cause of this is a faulty fuel pump check valve that allows fuel to drain back into the tank, or one or more leaking fuel injectors which allows the fuel to leak into the engine.

 

to check for this, fuel pressure needs to be tested and monitored while the car is running and then monitored after the engine is shut off to see if it bleeds off.

 

this is the testing that needs to be carried out at this time

 

other possible causes would be a faulty temp sensor or possibly a weak battery or starter,

 

Sorry if you were hoping for a different answer, please don't shoot the messenger - I can only give the honest answer, which I have. Please remember that a low rating PUNISHES me for my honest and prompt response, and I receive nothing for my time and answer until a positive rating is clicked.

Please let me know if you have further questions. Please do not forget to click a positive rating as this is the only way I receive credit for my answer, thank you. Best wishes with your vehicle.

Steve and other BMW Specialists are ready to help you