How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Steve Your Own Question
Steve
Steve, BMW Expert
Category: BMW
Satisfied Customers: 23903
Experience:  BMW Expert
26942375
Type Your BMW Question Here...
Steve is online now

Hi. I have a 2003 BMW Z4 E85 3.0i. 2 days ago, after disconnecting

Resolved Question:

Hi. I have a 2003 BMW Z4 E85 3.0i. 2 days ago, after disconnecting the battery and fitting a new slip ring, the aircon, electric roof, indicator light in the cabin, central locking from the keyfob all failed, also the airbag light came on. It appears no power is getting to them although the car starts and runs perfectly. Tried again several times yesterday, after checking every fuse was Ok, but still nothing worked. Then, after 10 mins I tried again and the hood suddenly worked for 3 up and down cycles(but the windows did not come partially down) after the third cycle the hood stayed down and would not respond again. The red light comes on when pushing the button but no sound. I have checked the tightness of the negative lead from the battery to the bodywork/chassis in the boot(trunk). Any ideas?.

Submitted: 3 years ago.
Category: BMW
Expert:  Steve replied 3 years ago.
Hello,

I will provide an honest answer. I trust this will be appreciated. Please remember that a low rating PUNISHES me for being honest and that I receive nothing for my time until a positive rating is clicked.

Your symptoms suggest the vehcile has gone back into transport mode which is a common problem on Z4s. Unfortunately the only way to get the vehicle out of transport mode is with a factory bmw scan tool or equivilent.

It is also possible you have a module failure or other component failure.

The air bag light is likely related to the slip ring installation, there may be a fault with the wheel air bag or the light may simply need to be turned off with a scanner.

The only thing you can really try without access to a factory bmw scanner would be to unhook the battery for an hour to see if anything will reset. Worth a shot.

Sorry if you were hoping for a different answer, please don't shoot the messenger - I can only give the honest answer, which I have. Please remember that a low rating PUNISHES me for my honest and prompt response, and I receive nothing for my time and answer until a positive rating is clicked.

Please let me know if you have further questions. Please do not forget to click a positive rating as this is the only way I receive credit for my answer, thank you. Best wishes with your vehicle.
Steve and other BMW Specialists are ready to help you
Customer: replied 3 years ago.

Hi. Thanks for that, it did seem to be some kind of shutdown as the roof has worked again for 2 operations and then stopped working again. Also the BMW factory sat nav screen has swung open at the push of the button a couple of times and then shut back down again. It is now refusing to open again. I have booked the car in with a BMW specialist on Monday. Thanks again, I appreciate an honest answer and will score the highest rating

Related BMW Questions