How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Steve Your Own Question
Steve
Steve, BMW Expert
Category: BMW
Satisfied Customers: 23874
Experience:  BMW Expert
26942375
Type Your BMW Question Here...
Steve is online now

my X reg 525 i petrol wipers have stopped working. it's not

Resolved Question:

my X reg 525 i petrol wipers have stopped working. it's not the fuse and seems to be not the relay as I have tried two others, apparantly there is no power getting to the wiper motor, any clues, please help
Submitted: 2 years ago.
Category: BMW
Expert:  Steve replied 2 years ago.

I will provide an honest answer. I trust this will be appreciated on a weekend. Please remember that a low rating PUNISHES me for being honest and that I receive nothing for my time until a positive rating is clicked.

if there is no power to the wiper motor and the fuses and relays are fine, I would next suspect the switch/stalk that is used to trigger the wipers, that could be bad

if the issue is not corrected with a new switch, then it is possible that the general module has failed - this is the module which controls the wipe/wash functions

you definitely want to be sure you checked the correct fuses and relay first.

of course, there could always be a broken wiring somewhere also, but that is rare and hard to predict

Please let me know if you have further questions. Please do not forget to click a positive rating as this is the only way I receive credit for my answer, thank you. Best wishes with your vehicle.


Steve and other BMW Specialists are ready to help you
Expert:  Steve replied 2 years ago.
hello
I will provide an honest answer. I trust this will be appreciated on a weekend. Please remember that a low rating PUNISHES me for being honest and that I receive nothing for my time until a positive rating is clicked.
if there is no power to the wiper motor and the fuses and relays are fine, I would next suspect the switch/stalk that is used to trigger the wipers, that could be bad
if the issue is not corrected with a new switch, then it is possible that the general module has failed - this is the module which controls the wipe/wash functions
you definitely want to be sure you checked the correct fuses and relay first.
of course, there could always be a broken wiring somewhere also, but that is rare and hard to predict
Please let me know if you have further questions. Please do not forget to click a positive rating as this is the only way I receive credit for my answer, thank you. Best wishes with your vehicle.

Related BMW Questions