How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Matt Your Own Question
Matt
Matt, Mechanical Engineer
Category: BMW
Satisfied Customers: 21991
Experience:  BEng hons Mech engineering, in auto industry 22 years
12772297
Type Your BMW Question Here...
Matt is online now

I have an 03 bmw 530d manual (e39) and when I accelerate

Resolved Question:

Hi. I have an 03 bmw 530d manual (e39) and when I accelerate hard in first and let off the throttle there is a banging noise coming from underneath the car. I have had the car inspected by 2 different garages and so far I've had any suspension bushings it needed replaced (and arms too) I had the diff oil changed and the propshaft coupling joint replaced. It's still doing it. Any other suggestions would be great help, thanks. Peter in Ireland
Submitted: 2 years ago.
Category: BMW
Expert:  Shantal-Mod replied 2 years ago.
Hello Peter,
I'm Shantal and I'm a moderator for this topic.
I've been working hard to find a Professional to assist you with your question, but sometimes finding the right Professional can take a little longer than expected.
I was checking to see if you had already found your answer or if you still need assistance from one of the Professionals.
Please let me know if you wish to continue waiting or if you would like for us to close your question?
Thank you,
Shantal
Customer: replied 2 years ago.
Hi shantal, no I still haven't discovered what the problem is with the car. It only makes the knocking noise under harsh acceleration in first and when letting off the throttle the banging almost sounds like the drivetrain flexing and knocking off the underbody or it could be the exhaust flexing and hitting off the underbody. I'm really not sure, any more information would be great, thanks
Expert:  Matt replied 2 years ago.
Hello this sounds like a worn mountings - check the tightness of the engine and gearbox mounts and their condition - this is best done by using a jack to take the weight of the engine off the mounts and seeing if any cracks or splits open up in the rubber.Also check the tightness of the mounts bolts and look for any black oil around the mounts as they are hydraulic
Matt, Mechanical Engineer
Category: BMW
Satisfied Customers: 21991
Experience: BEng hons Mech engineering, in auto industry 22 years
Matt and other BMW Specialists are ready to help you