How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Steve Your Own Question
Steve
Steve, BMW Expert
Category: BMW
Satisfied Customers: 24421
Experience:  BMW Expert
26942375
Type Your BMW Question Here...
Steve is online now

I am having problems with my bmw 318i 54 plate n46. It keeps

Resolved Question:

I am having problems with my bmw 318i 54 plate n46. It keeps entering eml limp mode with 2 valvetronic faults, but only happens when starting engine from warm, and dissapear after engine is cool any ideas
Submitted: 1 year ago.
Category: BMW
Expert:  Steve replied 1 year ago.
What faults exactly do you have?
Customer: replied 1 year ago.
It's fine starting from cold but say I went shopping and engine was at temperature and turned it off, when I come out to start it it would go to limp mode but not every time, fault code P1050 and P1062 come up showing valvonic faults, but it randomly goes back off when left for 30 mins, and no faults what so ever
Expert:  Steve replied 1 year ago.
I will provide an honest answer. I trust this will be appreciated. Please remember that a low rating PUNISHES me for being honest and that I receive nothing for my time until a positive rating is clicked.
these faults suggest a problem most likely with the eccentric shaft sensor or actuator motor. Possibly but less likely the control module.
unfortunately p codes are not definitive so further checks of the sensor and actuator will be required - and ideally a proper scan and test plan on a factory BMW scan tool which is designed to diagnose this system. p codes unfortunately give the minimum info required by emissions law and are not helpful with regards ***** ***** valvetronic systsem
the sensor is the most common failure for these codes and both the sensor and actuator can play up intermittently
Please let me know if you have further questions. Please do not forget to click a positive rating as this is the only way I receive credit for my answer, thank you. Best wishes with your vehicle.
Customer: replied 1 year ago.
Yea I will rate you for your time. I took it to a bmw specialist and they couldn't find a problem as they said the fault never came back once erased, the two sensors your suggesting where roughly are they located and are they pricey parts? Many thanks for your time and help
Expert:  Steve replied 1 year ago.
what is the last 7 digits of the vin?
Customer: replied 1 year ago.
Kc37694
Expert:  Steve replied 1 year ago.
the sensor is at the very front of the engine. the actuator motor sticks out of the top of the engine. here are pics: https://c1552172.ssl.cf0.rackcdn.com/314518_x800.jpg https://encrypted-tbn2.gstatic.com/images?q=tbn:ANd9GcRORMCPXrNU7Kfha79C9MCzXgKLs0HDwkhsltpXZ9MBFKO6zQdj-Q
Expert:  Steve replied 1 year ago.
they are moderately expensive, probably about 300gbp each depending on where you buy. they can be found for less online
Expert:  Steve replied 1 year ago.
*********** and *********** are the part numbers so you can call around / search locally and online
Expert:  Steve replied 1 year ago.
please do not forget to CLICK ON a positive rating
Expert:  Steve replied 1 year ago.
Please let me know if you have further questions. Please do not forget to click a positive rating as this is the only way I receive credit for my answer, thank you. Best wishes with your vehicle.
Expert:  Steve replied 1 year ago.
hello, did you have any additional questions? is not, please kindly select a positive rating. if you would like to follow up after leaving a positive rating you are free to do so at any time without additional charge after leaving a positive rating
thank you
Steve and other BMW Specialists are ready to help you