How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Steve Your Own Question
Steve
Steve, BMW Expert
Category: BMW
Satisfied Customers: 24178
Experience:  BMW Expert
26942375
Type Your BMW Question Here...
Steve is online now

I have an 09 BMW 320i. last week I was just driving along

Resolved Question:

I have an 09 BMW 320i. last week I was just driving along the road, about 3 miles into an 5 mile journey. All of a sudden, with no warning and no previous history, I have a complete power failure. Everything went dead, the electrics, lights, central locking, engine, power steering, car locks, windows etc. etc. There was no warning or lights prior to the event. I had to coast to safety and stop, thankfully I was not in any dangerous area like a motorway. Even the gauges on the dashboard stayed indicating exactly as per prior to the power failure. Could not get into the boot to get to the battery. tried jump starting to no avail, completely dead of power. About two hours later for no apparent reason, the power restored, the doors opened and the gauges returned to zero. Have you ever heard of this before and what would you suggest was the problem and potential rectification? Many thanks.
Submitted: 1 year ago.
Category: BMW
Expert:  Steve replied 1 year ago.
what is the last 7 digits of the vin?
Customer: replied 1 year ago.
Is that,the chassis number or the reg?
Customer: replied 1 year ago.
OK, I have it, sorry. - A400099
Expert:  Steve replied 1 year ago.

I will provide an honest answer. I trust this will be appreciated. Please remember that a low rating PUNISHES me for being honest and that I receive nothing for my time until a positive rating is clicked.
.
Thank you for your attention to the rating requirement.

.

assuming there are no loose battery cables/connections, there are a few things that can cause this. most likely it is a problem with the positive battery cable or with melting/hot spot development at the fuse panel. both are common on this car. the other less likely possibility would be an issue with the battery unit (the plastic box on top of the battery)
.
Please let me know if you have further questions. Please do not forget to click a positive rating as this is the only way I receive credit for my answer, thank you. Best wishes with your vehicle.

Steve and other BMW Specialists are ready to help you