How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Matt Your Own Question
Matt
Matt, Mechanical Engineer
Category: BMW
Satisfied Customers: 108
Experience:  BEng hons Mech engineering, in auto industry 22 years
12772297
Type Your BMW Question Here...
Matt is online now

I would like to ask regarding to an engine on my X5 E70

Customer Question

Hi There,
I would like to ask regarding to an engine on my X5 E70 3.0si 2008/05 EUR
Submitted: 1 year ago.
Category: BMW
Customer: replied 1 year ago.
I do not drive it too much and it has 50K km on the clock. I only take it to BMW service but have just started having this problem with engine. Every time i start the engine, RPMs go up to 1500 then back to 1000 and then slow back to 600 until an engine temperature falls into working range. I can feel vibration and fluctuation of RPMs which lasts 2 - 3 sec between 1000 and 600rpm then it becomes quite. It happens every time does not matter if the engine is cold or hot. My mechanic was suspecting VANOS problem especially after having VANOS inlet solenoid sticking fault but I changed both solenoids (inlet / outlet) and that fault dispensary. But It is still vibrating every time I start the engine. Another thing related to this problem is, I noticed that idle became rough, fuel consumption increased and i could start an engine only from the third attempt last time.
Expert:  Steve replied 1 year ago.
hello,
are any warning lights on?
Customer: replied 1 year ago.
Hi Steve,The bash board is completely free of any errors.
Expert:  Steve replied 1 year ago.

thanks. originally you said it happens until the car gets to working temperature, but you also say it happens if you start when the engine is already hot. can you please clarify?

Customer: replied 1 year ago.
Basically it happens 95% times when I start the engine. As I mentioned previously, I drive the car only 6 months per year due to my working schedule. This problem started improving because I never had an issue with ignition but as I mentioned previously it did not ignite from the first attempt this time. I do not know if it is because of weather conditions (getting cold) or something else. It is more noticeable when the engine is cold but I still have the same symptoms when the engine is hot. And obviously it does nothing when I go to workshop.