How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Matt Your Own Question
Matt
Matt, Mechanical Engineer
Category: Car
Satisfied Customers: 21981
Experience:  BEng hons Mech engineering, in auto industry 22 years
12772297
Type Your Car Question Here...
Matt is online now

my timing belt snapped on a 2.5dci renault master, I took the

Customer Question

my timing belt snapped on a 2.5dci renault master, I took the head off and had it checked, everything was fine no damage, re-assembled everything set it up with the timing marks but it will not start, could something else be damaged? it was running fine until the belt snapped any help would be appreciated.
Submitted: 4 years ago.
Category: Car
Expert:  Matt replied 4 years ago.
Hello

if you're confident that all the marks are lined up then I'd suggest doing a compression test across all cylinders as they should all be within 10-15 psi of each other as this is an interference engine so its possible valves have hit pistons and are bent

sorry its not better news

but a compression test will show one way or another
Customer: replied 4 years ago.

As I said in my original question the head has been off and the valves checked for straightness in a lathe so this is not the problem, any other ideas?

Expert:  Matt replied 4 years ago.
Hello Ashley

OK if there's no damage its still worth doing a compression test as this will show / confirm that the cam timing is correct - if its not you'll have two low cylinders


Also if its not injecting at all then check the connections to the crankshaft sensor, unplug it and check for corroded contacts and broken wiring, and consider fitting a new sensor - do the same for the cam position sensor

If the EGR valve is stuck open then this too can effect starting so try disconnecting it to see if this helps or changes anything