How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Mike Kelly Your Own Question
Mike Kelly
Mike Kelly, Auto Service Technician
Category: Car
Satisfied Customers: 5470
Experience:  17 years experience as an auto mechanic, foreign and domestic. 5 years running my own repair business.
19374685
Type Your Car Question Here...
Mike Kelly is online now

I have a MB CLK 230K Auto, 98 plate. Just had it serviced a

Customer Question

I have a MB CLK 230K Auto, 98 plate. Just had it serviced a week ago, driven it twice without problems but now the car starts & idles fine but when I select drive it starts to shake and feels like its misfiring with hardly any acceleration. Any ideas?

Submitted: 4 years ago.
Category: Car
Expert:  Mike Kelly replied 4 years ago.
Hi,my name is mike and I will assist you with your question.
What type of serviced was performed?
Also are there any warning lights coming on?
Customer: replied 4 years ago.

Just had oil/fluids change as it was a full service done last year. No warning lights on at all.

Expert:  Mike Kelly replied 4 years ago.
Ok the issue that you are describing and the fact that this happens when the vehicle is in gear is consistent with a vacuum line that has popped free and the vehicle is sucking air. What I would suggest as a first step is to have the vacuum lines checked around the intake manifold and leading to the gear box.