How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Mike Kelly Your Own Question
Mike Kelly
Mike Kelly, Auto Service Technician
Category: Car
Satisfied Customers: 5470
Experience:  17 years experience as an auto mechanic, foreign and domestic. 5 years running my own repair business.
19374685
Type Your Car Question Here...
Mike Kelly is online now

Berlingo Van 1.9 600LX, New Battery, no charging light showing,

Customer Question

Berlingo Van 1.9 600LX, New Battery, no charging light showing, keeps going flat, will start with Jump holds power to restart, then leave it for 2 days. it is dead again. No Lights, radio, or any extras plugged in to drain it. as soon as i turn key eco mode shows up on display.
Any help would be much appreciated
Submitted: 3 years ago.
Category: Car
Expert:  Mike Kelly replied 3 years ago.
Hi,my name is mike and I will assist you with your question.
The issue that you are describing is consistent with a ground/earth connection or a faulty ignition switch. What I would suggest as a first step is to inspect the connections at the battery,battery leading to the alternator,and the battery leading to the starter. If all connections check out and the connections are tight and not corroded or frayed then the ignition switch is keeping power supplied when it should not and draining the battery.