How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Greg Your Own Question
Greg
Greg, Technician
Category: Car
Satisfied Customers: 7065
Experience:  Automotive diagnostic tech
29331485
Type Your Car Question Here...
Greg is online now

Hi I have a audi a4 3.2 2005 petrol you can leave the car running

Customer Question

Hi I have a audi a4 3.2 2005 petrol you can leave the car running for a hour then just cuts out when hot then it's hard to start have to leave it to cool then it would start again had a lot of work done on the fuel said but no joy can you help
Submitted: 3 years ago.
Category: Car
Expert:  Greg replied 3 years ago.
Did you check for any possible malfunction codes .

If you did what where the codes.

Greg
Customer: replied 3 years ago.

One a load signal from ecu p1857 and one low pressure fuel g410 intermittent p2543 sporadic 099 open to short to ground

Expert:  Greg replied 3 years ago.
Hi Eddie ,

The shop has missed the deal on this one as your problem is your MAF sensor .
I suggest you try another MAF sensor ,
I say try as you don't have the needed dealership toolsd to be sure as this is a Load Signal P1857 - 35-10 - Error Message from ECU - Intermittent.
Load is usually calculated off MAF.

Check for any vacuum leaks first and make sure you check this well as any leak after the MAF will do this issue you are having .
Then remove the maf and try another .

Please get back to me if needed ,be more than happy to help further if i can .



Greg
Customer: replied 3 years ago.

Ok but car drive fine if you let the car idle for about 45 min it would just cut out like something getting hot then you have to leave it for a wile before you can drive it again it holds back and cuts out

Expert:  Greg replied 3 years ago.
Hi Eddie.

Just read in the Audi TSB that there is a new software update for the ECM that will resolve your problem .
Check at your local Audi dealer and have this certified that this is your problem .
Please check this out then get back to me .

Rgds Greg
Greg and other Car Specialists are ready to help you
Customer: replied 3 years ago.

Hi they say the problem is the car getting to hot this y it cuts out and runs rough they letting the electrition look at it they think it's the fan module

Expert:  Greg replied 3 years ago.
Hi Eddie .

Yes this is a very possible issue but then your temp gauge would show you your overheating .
When idling and the temp is at normal temp does the fans come on
and off, and this would also in most case trip on the check engine light
Greg
Customer: replied 3 years ago.

Temperature gauge stays half way and they say the fans are working but the computer says the engine running to hot the fan should come onabout 98 but come in on about 115 they changed the temp switch thanks .

Expert:  Greg replied 3 years ago.
Hi Eddie .

Thank you and wish you all the best .

Kindest regards Greg