How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Matt Your Own Question
Matt
Matt, Mechanical Engineer
Category: Car
Satisfied Customers: 21625
Experience:  BEng hons Mech engineering, in auto industry 22 years
12772297
Type Your Car Question Here...
Matt is online now

opel insignia malfunction light stays on looses power sometimes

Customer Question

opel insignia malfunction light stays on looses power sometimes engine gets hot temperature guage ok fan comes on when car is stopped why would u think garage said they plug it in car is under guarantee so i need to know so i can get it fixed under warranty please
Submitted: 3 years ago.
Category: Car
Expert:  Matt replied 3 years ago.
Hello

if the light is on then if you get a check engine light or other fault light this typically means one or more of the sensors has failed or has a faulty connection.

The ECU senses this and may put the car into 'limp home' mode which typically limits the revs and the amount of power available. Usually the car is safe to drive for a short distance as the mode is intended is intended to get you home without incurring any engine damage

The quickest route to repair is to have the car plugged into a diagnostic machine which will read off the fault code stored in the ECU (providing the light is still on at this point) and indicate which sensor has failed or whether the fault is more serious.

You can do a very rough and ready check yourself by unplugging sensors one at a time and seeing if any of them change the driving condition which would indicate the most recently unplugged sensor is the faulty one. This method is not foolproof though and reading a fault code off is the better method

from your description I'd say its an issue with the wiring as things tend to expand when hot and its possible a poor or partial electrical connection is being pushed apart on one of the major sensors so check the connection plug and wiring to the following;
Airflow meter
Crank position sensor
Cam position sensor
O2 sensor
Throttle position sensor

Related Car Questions