How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Matt Your Own Question
Matt
Matt, Mechanical Engineer
Category: Car
Satisfied Customers: 21623
Experience:  BEng hons Mech engineering, in auto industry 22 years
12772297
Type Your Car Question Here...
Matt is online now

My son has an 07 Renault Clio Campus Sport 1.2 16v and it cuts

Customer Question

My son has an 07 Renault Clio Campus Sport 1.2 16v and it cuts out with no warning causing loss of engine power, cd, power steering, lights etc rectified only by stopping, turni g off ignition key and restarting engine. Car may run for days if not weeks before the same problem occurs, has happened on motorways whilst overtaking, other than that car seems to run fine have taken it back to garage (only purchased in January) diagnostic test revealed nothing, garage changed the battery, i feel they don't have a clue and are clutching at straws CAN U HELP?
Submitted: 3 years ago.
Category: Car
Expert:  Matt replied 3 years ago.

Hello


This sounds like an electrical actuator or sensor at fault .Usually when you can cycle the ignition key on / off and then restart the engine and the fault is gone temporarily this indicates that this is an electrical component causing this issue.

This could be a wiring issue as things tend to expand when hot and its possible a poor or partial electrical connection is being pushed apart on one of the major sensors so check the connection plug and wiring to the following;

Airflow meter

Crank position sensor

Cam position sensor

O2 sensor

Throttle position sensor

Also worth checking the connections to the fuel pump for the same reason - unplug each in turn and give them a good squirt of switch / contact cleaner - Not WD40

and also unplug and inspect the main power relays and fuses for signs of overheating or corroded terminals - so the ones for the ECU and the fuel pump

And also unplug the wiring loom connections in the engine bay one at time and inspect for corroded or recessed pins.

Also replace the spark plugs if any of them fail this checklist:

http://www.ngksparkplugs.com/tech_support/spark_plugs/faqs/faqread.asp

Also its worth checking that the electric pump that feeds the injectors is working correctly, it should run for a few seconds then switch off when you first turn the ignition on. If the connections to this are corroded or damaged then the pump could stop at any time. Check that its relay switches in and out and the relay contacts are clean and bright – replace the relay if in any doubt and do the same for the fuse, ideally measure the voltage at the pump and check its getting 12V

Related Car Questions